summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2019-06-26 16:21:26 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-27 13:29:30 +0000
commitf048f1929149d6ae99f532031e09af67f6f49ac7 (patch)
treebcd73712826453da417a5a32e4d9500e0491fadf
parentdfa9b626a76f908ec2355bae3d21c67d810fd500 (diff)
meta-pipewire: add patch to security-manager for pipewire
This grants permission to all applications to be able to communicate with pipewire. This is a temporary measure that we need to rethink in the future. This commit also changes the priority of the meta-pipewire layer because the security-manager patch needs to be applied after the patch to the same file from meta-app-framework, which has priority 70. Bug-AGL: SPEC-2554 Change-Id: I9df47ea1a40e1fa97900bb5dbc21bc11765eb7ab Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
-rw-r--r--meta-pipewire/conf/layer.conf2
-rw-r--r--meta-pipewire/recipes-security/security-manager/security-manager/0001-Adapt-smack-rules-to-allow-connections-to-pipewire.patch25
-rw-r--r--meta-pipewire/recipes-security/security-manager/security-manager_%.bbappend2
3 files changed, 28 insertions, 1 deletions
diff --git a/meta-pipewire/conf/layer.conf b/meta-pipewire/conf/layer.conf
index bd56479c..8ad06e3e 100644
--- a/meta-pipewire/conf/layer.conf
+++ b/meta-pipewire/conf/layer.conf
@@ -7,6 +7,6 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "meta-pipewire"
BBFILE_PATTERN_meta-pipewire = "^${LAYERDIR}/"
-BBFILE_PRIORITY_meta-pipewire = "8"
+BBFILE_PRIORITY_meta-pipewire = "71"
LAYERSERIES_COMPAT_meta-pipewire = "thud"
diff --git a/meta-pipewire/recipes-security/security-manager/security-manager/0001-Adapt-smack-rules-to-allow-connections-to-pipewire.patch b/meta-pipewire/recipes-security/security-manager/security-manager/0001-Adapt-smack-rules-to-allow-connections-to-pipewire.patch
new file mode 100644
index 00000000..821c1e1d
--- /dev/null
+++ b/meta-pipewire/recipes-security/security-manager/security-manager/0001-Adapt-smack-rules-to-allow-connections-to-pipewire.patch
@@ -0,0 +1,25 @@
+From cc5cbaddad6fe559e9e482467266fb18fb00c6a7 Mon Sep 17 00:00:00 2001
+From: George Kiagiadakis <george.kiagiadakis@collabora.com>
+Date: Wed, 26 Jun 2019 16:02:13 +0300
+Subject: [PATCH] Adapt smack rules to allow connections to pipewire
+
+Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com>
+---
+ policy/app-rules-template.smack | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/policy/app-rules-template.smack b/policy/app-rules-template.smack
+index 910f40c..78b75de 100644
+--- a/policy/app-rules-template.smack
++++ b/policy/app-rules-template.smack
+@@ -4,6 +4,7 @@ System ~PKG~ rwxat
+ ~APP~ System::Shared rx
+ ~APP~ System::Run rwxat
+ ~APP~ System::Log rwxa
++~APP~ System::Pipewire rw
+ ~APP~ _ l
+ ~APP~ User::Home rxl
+ ~APP~ User::App-Shared rwxat
+--
+2.20.1
+
diff --git a/meta-pipewire/recipes-security/security-manager/security-manager_%.bbappend b/meta-pipewire/recipes-security/security-manager/security-manager_%.bbappend
new file mode 100644
index 00000000..319a27d6
--- /dev/null
+++ b/meta-pipewire/recipes-security/security-manager/security-manager_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/security-manager:"
+SRC_URI += "file://0001-Adapt-smack-rules-to-allow-connections-to-pipewire.patch"