aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-01-20 17:26:59 -0500
committerScott Murray <scott.murray@konsulko.com>2020-01-20 22:41:12 +0000
commit3df10d0f1f92a3ec378a330cb98a1416980781b2 (patch)
tree77740f64796b7c4d47c18dd6e0d0bf887be75308
parentddb82bacfdadbe9c7ab5050b50d20cc5f1c14c35 (diff)
meta-aac: Rework agl-voiceagent-alexa packaging
Rather than appending the agl-voiceagent-alexa packages onto the existing packagegroup-agl-core-services, instead define a new specific packagegroup-agl-voiceagent-alexa, and an associated image feature that is used to include it into an image with IMAGE_FEATURES. This seems better for the longer-term goal of a binary package feed, and IMAGE_FEATURES can be used by other recipes in a similar manner as DISTRO_FEATURES, but with a lot less build dependency impact if changed. This will be used in a parallel change to meta-agl-demo to pull in the new alexa-viewer application when using the Alexa voiceagent. Bug-AGL: SPEC-3110 Change-Id: I15fb07560fef703e3471bce9e50596cb4a6667b4 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-speech-framework/conf/include/agl-voiceagent-alexa.inc4
-rw-r--r--meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb15
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
index 7b478474..10df0926 100644
--- a/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
+++ b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
@@ -4,3 +4,7 @@
BBMASK += "meta-aac/recipes-support/curl/curl_%.bbappend"
PREFERRED_RPROVIDER_virtual/voice-high-config = "alexa-voice-high-config"
+
+FEATURE_PACKAGES_agl-voiceagent-alexa = "packagegroup-agl-voiceagent-alexa"
+
+IMAGE_FEATURES += "agl-voiceagent-alexa"
diff --git a/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb b/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
new file mode 100644
index 00000000..5f38e7ef
--- /dev/null
+++ b/meta-speech-framework/meta-aac/recipes-platform/packagegroups/packagegroup-agl-voiceagent-alexa.bb
@@ -0,0 +1,15 @@
+SUMMARY = "The software for the AGL Alexa voiceagent feature"
+DESCRIPTION = "The software for the AGL Alexa voiceagent feature"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-voiceagent-alexa \
+"
+
+RDEPENDS_${PN} += " \
+ alexa-voiceagent-service \
+ ${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", "virtual/alexa-voiceagent-config", "",d)} \
+"