aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-10 10:31:02 -0400
committerScott Murray <scott.murray@konsulko.com>2019-10-10 10:33:09 -0400
commit472dba34fc8f174ac3bef7901b1d186d801f257a (patch)
tree4bf4cd87ccee7865b5524e20b8901b2433ec4856
parent5fd9793209ba94d8677965a957c40f89ea870bd2 (diff)
agl-service-voice-high-capabilities: remove submodule usage
Update agl-service-voice-high-capabilities recipe to replace git submodule usage with DEPENDS on libafb-helpers and libappcontroller. nlohmann-json has been added also been added as a dependency since the json.hpp it provides is no longer available from libafb-helpers as it previously was from the submodule. Finally, the lua dependencies have been removed since nothing in the binding's controller usage requires them. Bug-AGL: SPEC-2855, SPEC-2857 Change-Id: I8e6eaa88c294b1c8d97c5eefab912e87aebd8e80 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-speech-framework/recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-speech-framework/recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb b/meta-speech-framework/recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb
index efeba097..6ab4da9c 100644
--- a/meta-speech-framework/recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb
+++ b/meta-speech-framework/recipes-apis/agl-service-voice-high-capabilities/agl-service-voice-high-capabilities_git.bb
@@ -6,14 +6,12 @@ SECTION = "apps"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-inherit cmake pkgconfig aglwgt
-
-DEPENDS += "lua lua-native"
-RDEPENDS_${PN} += "lua"
+DEPENDS = "libafb-helpers libappcontroller nlohmann-json"
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high-capabilities.git;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-voice-high-capabilities.git;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
+inherit cmake pkgconfig aglwgt