aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-11-27 11:05:01 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-06 14:31:47 +0000
commitfca7f231bf522024d50303c8f6c6adc3b0b5dee6 (patch)
tree78bf885c14d35af4055d8fa708f0c3dcb2695c12
parent179b11e41b192828a4667bc987bf42b3d9cfc4d2 (diff)
meta-html5-framework: define html-only image
The layer now defines a standalone image agl-image-graphical-html5, containing only the minimum packages to run the web application manager (WAM). No webapps are included. It redefines packagegroups to use the more standard names agl-profile-graphical-html5 and agl-appfw-html5. It also adds a dependency on agl-profile-graphical, so we don't require users to add other features explicitly. The .bbappends for agl-demo-platform* images have been removed, so the layer doesn't depend on meta-agl-demo. We will provide image definitions for WAM + demo apps in meta-agl-demo in a later commit. To sum up, an HTML-only image can be built with: aglsetup.sh -m $MACHINE agl-html5-framework bitbake agl-image-graphical-html5 To add WAM to an agl-demo-platform image, both agl-demo and agl-html5-framework features must be enabled, and this must be added to local.conf or local.dev.inc: IMAGE_INSTALL_append = " packagegroup-agl-appfw-html5" Bug-AGL: SPEC-2322 Change-Id: I648dd9f509faf77bf0c8520c9773de073865b90e Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
-rw-r--r--meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend3
-rw-r--r--meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend3
-rw-r--r--meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb10
-rw-r--r--meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc9
-rw-r--r--meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb18
-rw-r--r--meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb26
-rw-r--r--meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-profile-graphical-html5.bb23
-rw-r--r--templates/feature/agl-html5-framework/included.dep1
8 files changed, 61 insertions, 32 deletions
diff --git a/meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend b/meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend
deleted file mode 100644
index d5d978dd..00000000
--- a/meta-html5-framework/recipes-platform/images/agl-demo-platform-crosssdk.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-IMAGE_INSTALL_append += "\
- packagegroup-agl-demo-platform-html5 \
- "
diff --git a/meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend b/meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend
deleted file mode 100644
index d5d978dd..00000000
--- a/meta-html5-framework/recipes-platform/images/agl-demo-platform.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-IMAGE_INSTALL_append += "\
- packagegroup-agl-demo-platform-html5 \
- "
diff --git a/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb
new file mode 100644
index 00000000..0ec6829e
--- /dev/null
+++ b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.bb
@@ -0,0 +1,10 @@
+SUMMARY = "An image containing all packages required to run web applications"
+
+require agl-image-graphical-html5.inc
+
+LICENSE = "MIT"
+
+IMAGE_INSTALL_append = "\
+ packagegroup-agl-profile-graphical-html5 \
+ "
+
diff --git a/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc
new file mode 100644
index 00000000..21f3b19a
--- /dev/null
+++ b/meta-html5-framework/recipes-platform/images/agl-image-graphical-html5.inc
@@ -0,0 +1,9 @@
+require recipes-platform/images/agl-image-minimal.inc
+
+IMAGE_FEATURES += "splash"
+
+IMAGE_FEATURES += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ssh-server-dropbear' , '', d)}"
+
+inherit distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
diff --git a/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb b/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb
new file mode 100644
index 00000000..cc9ed3d6
--- /dev/null
+++ b/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-appfw-html5.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL web runtime packages"
+DESCRIPTION = "Specific packages for the AGL web runtime (minus profile-graphical)"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-appfw-html5 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+# add packages for WAM
+RDEPENDS_${PN} += " \
+ chromium-browser-service \
+ wam \
+ "
diff --git a/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb b/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
deleted file mode 100644
index c4e3c0d7..00000000
--- a/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb
+++ /dev/null
@@ -1,26 +0,0 @@
-SUMMARY = "The software for DEMO platform of AGL IVI profile"
-DESCRIPTION = "A set of packages belong to AGL Demo Platform"
-
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-demo-platform-html5 \
- "
-
-ALLOW_EMPTY_${PN} = "1"
-
-RDEPENDS_${PN} += "\
- packagegroup-agl-image-ivi \
- "
-
-# add packages for demo platform (include demo apps) here
-RDEPENDS_${PN} += " \
- "
-
-# add packages for WAM
-RDEPENDS_${PN} += " \
- chromium-browser-service \
- wam \
- "
diff --git a/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-profile-graphical-html5.bb b/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-profile-graphical-html5.bb
new file mode 100644
index 00000000..20275014
--- /dev/null
+++ b/meta-html5-framework/recipes-platform/packagegroups/packagegroup-agl-profile-graphical-html5.bb
@@ -0,0 +1,23 @@
+SUMMARY = "AGL web runtime profile"
+DESCRIPTION = "The full set of packages required for AGL web runtime"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-profile-graphical-html5 \
+ profile-graphical-html5 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-profile-graphical \
+ packagegroup-agl-appfw-html5 \
+"
+
+RDEPENDS_${PN} += "\
+ agl-login-manager \
+ "
+
+RDEPENDS_profile-graphical-html5 = "${PN}"
diff --git a/templates/feature/agl-html5-framework/included.dep b/templates/feature/agl-html5-framework/included.dep
new file mode 100644
index 00000000..032609b8
--- /dev/null
+++ b/templates/feature/agl-html5-framework/included.dep
@@ -0,0 +1 @@
+agl-profile-graphical