summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-13 07:17:54 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-11-22 15:39:06 +0900
commit4a19c32921e12a0897a4546281da271408047b4c (patch)
treea0b4a9c1bcac55b7f1ace06402d681ad36b2e902
parentd4cfeea4e2ab3d830b81c8022744e2a6511528fd (diff)
BUG FIX: mominavi is not showing map
Current ivi-demo is not showing map. It has some bugs. Not enabling the mapbox plugin in qtlocation. Not enabling the sqlite in qt-base. Not including the font in image. Not including the ca-certificates in image. This patch fix these issue. Bug-AGL: SPEC-4095 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: Icbc2378500a5230571a2f5a79e1e0ba0a1ddce97
-rw-r--r--meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb8
-rw-r--r--meta-agl-lxc/recipes-qt5/qt5/qtbase_git.bbappend1
-rw-r--r--meta-agl-lxc/recipes-qt5/qt5/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch47
-rw-r--r--meta-agl-lxc/recipes-qt5/qt5/qtlocation_git.bbappend7
4 files changed, 63 insertions, 0 deletions
diff --git a/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb b/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb
index 9a18444d..4c9dd177 100644
--- a/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb
+++ b/meta-agl-lxc/recipes-platform/images/guest-image-ivi-demo.bb
@@ -14,4 +14,12 @@ IMAGE_INSTALL += " \
qtquickcontrols2 \
qtwayland \
systemd-netif-config \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
+ ttf-dejavu-sans-condensed \
+ ttf-dejavu-serif \
+ ttf-dejavu-serif-condensed \
+ ttf-dejavu-mathtexgyre \
+ ttf-dejavu-common \
+ ca-certificates \
"
diff --git a/meta-agl-lxc/recipes-qt5/qt5/qtbase_git.bbappend b/meta-agl-lxc/recipes-qt5/qt5/qtbase_git.bbappend
new file mode 100644
index 00000000..7f2e9aa3
--- /dev/null
+++ b/meta-agl-lxc/recipes-qt5/qt5/qtbase_git.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG:append:aglcontainerivi = " sql-sqlite"
diff --git a/meta-agl-lxc/recipes-qt5/qt5/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch b/meta-agl-lxc/recipes-qt5/qt5/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch
new file mode 100644
index 00000000..ba8a991e
--- /dev/null
+++ b/meta-agl-lxc/recipes-qt5/qt5/qtlocation/0001-mapbox-update-API-url-to-match-new-schema.patch
@@ -0,0 +1,47 @@
+From 58197439eade86e7efc6fe98116c0092ea429d29 Mon Sep 17 00:00:00 2001
+From: Matt Ranostay <matt.ranostay@konsulko.com>
+Date: Tue, 10 Mar 2020 13:59:58 -0700
+Subject: [PATCH] mapbox: update API url to match new schema
+
+---
+ src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp | 7 ++++---
+ src/plugins/geoservices/mapbox/qmapboxcommon.h | 2 +-
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp b/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp
+index 0b128556..bd2be6b6 100644
+--- a/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp
++++ b/src/plugins/geoservices/mapbox/qgeotilefetchermapbox.cpp
+@@ -88,12 +88,13 @@ QGeoTiledMapReply *QGeoTileFetcherMapbox::getTileImage(const QGeoTileSpec &spec)
+ request.setRawHeader("User-Agent", m_userAgent);
+
+ request.setUrl(QUrl(mapboxTilesApiPath +
+- ((spec.mapId() >= m_mapIds.size()) ? QStringLiteral("mapbox.streets") : m_mapIds[spec.mapId() - 1]) + QLatin1Char('/') +
++ m_mapIds[m_mapIds.size() - 1] +
++ QStringLiteral("/tiles/256/") +
+ QString::number(spec.zoom()) + QLatin1Char('/') +
+ QString::number(spec.x()) + QLatin1Char('/') +
+ QString::number(spec.y()) +
+- ((m_scaleFactor > 1) ? (QLatin1Char('@') + QString::number(m_scaleFactor) + QLatin1String("x.")) : QLatin1String(".")) +
+- m_format + QLatin1Char('?') +
++ ((m_scaleFactor > 1) ? (QLatin1Char('@') + QString::number(m_scaleFactor) + QLatin1String("x")) : QLatin1String("")) +
++ QLatin1Char('?') +
+ QStringLiteral("access_token=") + m_accessToken));
+
+ QNetworkReply *reply = m_networkManager->get(request);
+diff --git a/src/plugins/geoservices/mapbox/qmapboxcommon.h b/src/plugins/geoservices/mapbox/qmapboxcommon.h
+index e60c4e83..4b2ea98d 100644
+--- a/src/plugins/geoservices/mapbox/qmapboxcommon.h
++++ b/src/plugins/geoservices/mapbox/qmapboxcommon.h
+@@ -46,7 +46,7 @@
+
+ QT_BEGIN_NAMESPACE
+
+-static const QString mapboxTilesApiPath = QStringLiteral("http://api.tiles.mapbox.com/v4/");
++static const QString mapboxTilesApiPath = QStringLiteral("https://api.mapbox.com/");
+
+ // https://www.mapbox.com/api-documentation/#geocoding
+ static const QString mapboxGeocodingApiPath = QStringLiteral("https://api.mapbox.com/geocoding/v5/mapbox.places/");
+--
+2.25.0
+
diff --git a/meta-agl-lxc/recipes-qt5/qt5/qtlocation_git.bbappend b/meta-agl-lxc/recipes-qt5/qt5/qtlocation_git.bbappend
new file mode 100644
index 00000000..674aabcd
--- /dev/null
+++ b/meta-agl-lxc/recipes-qt5/qt5/qtlocation_git.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/qtlocation:"
+
+SRC_URI += "\
+ file://0001-mapbox-update-API-url-to-match-new-schema.patch \
+ "
+
+PACKAGECONFIG:append:aglcontainerivi = " geoservices_mapbox geoservices_mapboxgl"