summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-10 00:35:39 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-11-22 15:32:01 +0900
commit3c60130d747e9dbee164b86bc489d3e3861c3662 (patch)
treea099135e44604f3994136ecc0161b82920e197f8
parent617b233850eea89d8962a59f273fa0d306684d05 (diff)
Fix multiple container installation failing
When new container image add into lxc-host-image-demo, existing image will not build. In case of: CONTAINER_IMAGES ?= "agl-container-cluster:guest-image-cluster-demo \ agl-container-ivi:guest-image-ivi-demo \ " agl-container-ivi:guest-image-ivi-demo will be building, but agl-container-cluster:guest-image-cluster-demo will not be building. This patch fix issue for the build dependency creation to guests. Bug-AGL: SPEC-4109 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: I2ed6f91f0d4db90f337a6148d6630f85c1b5c97d
-rw-r--r--meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb b/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
index f9c17448..17902447 100644
--- a/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
+++ b/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
@@ -22,7 +22,7 @@ python __anonymous() {
for c in (d.getVar('CONTAINER_IMAGES') or "").split():
(mc, image) = c.split(':')
dependency = 'mc::' + mc + ':' + image + ':do_image_complete'
- d.setVarFlag('do_rootfs', 'mcdepends', dependency)
+ d.appendVarFlag('do_rootfs', 'mcdepends', ' ' + dependency)
# Assume there is a X-lxc-config package for guest-image-X
config = image