summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-11-10 23:44:54 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-11-22 15:33:52 +0900
commitc38662f04db6aa45b72ae555e713d3febf91987a (patch)
treed8c0d6cd548a6b355e1e63b445a75be2b5c35d99
parent299f87d96044c4c1203d74decaa8b9bb979099b9 (diff)
Fix url and recipe style error in wayland-ivi-extension recipe
The recipe of wayland-ivi-extension has some issue. 1. GENIVI was rebrands as COVESA. As a resule, Github organization name change to COVESA from GENIVI. 2. Original recipe has some error for recipe style. 3. Using http protocol at downloading. This patch fix these issue. Bug-AGL: SPEC-4096 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: Ic961ddecf7f2f30a024a4caef0c444391e493224
-rw-r--r--meta-agl-lxc/recipes-graphics/wayland/wayland-ivi-extension_2.2.0.bb34
1 files changed, 16 insertions, 18 deletions
diff --git a/meta-agl-lxc/recipes-graphics/wayland/wayland-ivi-extension_2.2.0.bb b/meta-agl-lxc/recipes-graphics/wayland/wayland-ivi-extension_2.2.0.bb
index 26227315..ba19f561 100644
--- a/meta-agl-lxc/recipes-graphics/wayland/wayland-ivi-extension_2.2.0.bb
+++ b/meta-agl-lxc/recipes-graphics/wayland/wayland-ivi-extension_2.2.0.bb
@@ -1,35 +1,33 @@
SUMMARY = "Wayland IVI Extension"
DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
-HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
-BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
+HOMEPAGE = "https://github.com/COVESA/wayland-ivi-extension"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
-SRCREV = "8d4c227ca0a1f836a769a051732a826abbf5d98a"
+DEPENDS = "weston virtual/libgles2 pixman wayland-native"
-SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http \
- file://01-ivi-input-controller-update-to-weston-7.patch \
- file://02-ivi-id-agent-update-to-weston-7-header.patch \
- file://03-ivi-id-agent-update-dependencies-to-build-on-weston-8.patch \
- file://0001-Fix-NULL-pointer-exception-in-case-of-no-input-devic.patch \
+PR = "r1"
+
+SRC_URI = " \
+ git://github.com/COVESA/${BPN}.git;protocol=https \
+ file://01-ivi-input-controller-update-to-weston-7.patch \
+ file://02-ivi-id-agent-update-to-weston-7-header.patch \
+ file://03-ivi-id-agent-update-dependencies-to-build-on-weston-8.patch \
+ file://0001-Fix-NULL-pointer-exception-in-case-of-no-input-devic.patch \
"
+SRCREV = "8d4c227ca0a1f836a769a051732a826abbf5d98a"
S = "${WORKDIR}/git"
-DEPENDS = "weston virtual/libgles2 pixman wayland-native"
-
inherit cmake
EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
-
-FILES_${PN} += "${datadir}/wayland-protocols/stable/ivi-application/ivi-application.xml"
-FILES_${PN} += "${libdir}/weston/*"
-FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
-
EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
-PR = "r1"
+FILES:${PN} += "${datadir}/wayland-protocols/stable/ivi-application/ivi-application.xml"
+FILES:${PN} += "${libdir}/weston/*"
+FILES:${PN}-dbg += "${libdir}/weston/.debug/*"
# Need these temporarily to prevent a non-fatal do_package_qa issue
-INSANE_SKIP_${PN} += "dev-deps"
-INSANE_SKIP_${PN}-dev += "dev-elf dev-so"
+INSANE_SKIP:${PN} += "dev-deps"
+INSANE_SKIP:${PN}-dev += "dev-elf dev-so"