summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-04 15:50:40 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-11-22 15:34:27 +0900
commitef1223062aa6c40c50d0ce127427fdccc2fe5e3d (patch)
treee59f6c1632a6665fd9320c3b7547560e78b7a970
parent904d655496c6be831c77a9c5d69cd1ab79abf738 (diff)
Importing the mediaplayer demo app
The momiplay is a mediaplayer example based on AGL sample app at CC release. Existing agl-appfw is difficult to integrate into linux container guest, because agl-appfw strongly depend SMACK label in host. The mominavi is not require agl-appfw. It's temporally solution for MM release. This patch import momiplay to create ivi guest for demo. Bug-AGL: SPEC-4094 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: Ic0213f50ba570db56282d07b3f4f775664f05f78
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay7
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service11
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb36
3 files changed, 54 insertions, 0 deletions
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay b/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay
new file mode 100644
index 00000000..4b855a1e
--- /dev/null
+++ b/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay
@@ -0,0 +1,7 @@
+#XDG_RUNTIME_DIR=
+QT_QPA_PLATFORM=wayland-egl
+QT_WAYLAND_DISABLE_WINDOWDECORATION=1
+QT_QPA_FONTDIR=/usr/share/fonts/truetype
+QT_IVI_SURFACE_ID=2011
+QT_WAYLAND_SHELL_INTEGRATION=ivi-shell
+HOME=/home/root
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service b/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service
new file mode 100644
index 00000000..e8fa2afe
--- /dev/null
+++ b/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=momiplayer
+After=multi-user.target
+
+[Service]
+Type=simple
+EnvironmentFile=/etc/default/momiplay
+ExecStart=/usr/bin/momiplay
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb b/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
new file mode 100644
index 00000000..94e4afc6
--- /dev/null
+++ b/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Momiyama mediaplayer example based on AGL sample app. at CC"
+DESCRIPTION = "The momiplay is a mediaplayer example based on AGL sample app. \
+ The momiplay is not require agl-appfw."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=17;md5=f4ad6901289f57f62d15bfefb5cc3633"
+
+PV = "0.2.0"
+
+inherit qmake5 systemd
+
+DEPENDS = "qtbase qtquickcontrols2 qtgraphicaleffects qtsvg qtmultimedia "
+RDEPENDS_${PN} = "qtsvg qtmultimedia "
+
+SRC_URI = "git://github.com/AGLExport/momiplayer.git;protocol=https \
+ file://momiplay.service \
+ file://momiplay \
+ "
+SRCREV = "b4715bf924ea295feaaf8fbdb4a9c3da75f57591"
+
+S = "${WORKDIR}/git"
+
+QT_INSTALL_PREFIX = "/usr"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "momiplay.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+do_install_append() {
+ install -d ${D}/lib/systemd/system
+ install -m 0644 ${WORKDIR}/momiplay.service ${D}/lib/systemd/system
+
+ install -m 0755 -d ${D}${sysconfdir}/default/
+ install -m 0755 ${WORKDIR}/momiplay ${D}${sysconfdir}/default/
+}
+
+FILES_${PN} += " ${systemd_unitdir} ${sysconfdir}/*/* "