summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-10 00:47:06 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-16 21:40:16 +0100
commit43e7fb353f90014affac8bd2de372877dc2080c7 (patch)
tree231f9434634a83225ea1a354586dbdc71d33b1dd
parentc3ae7f9849428a49c077e4b4d212c44ba916c0fb (diff)
Re-structure for guests
In previously patch, I created new guest image for ivi demo. As a trial result using initial patch, I think so need to common OVERRIDES keyword and specific OVERRIDES keyword. This patch create cluster specific config and modify OVERRIDES keyword. Bug-AGL: SPEC-4099 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: I8c39f2a1fade2e0cc920a2efe9625678b07fb37b
-rw-r--r--meta-agl-lxc/conf/multiconfig/agl-container-cluster.conf29
-rw-r--r--meta-agl-lxc/conf/multiconfig/agl-container-guest.conf2
-rw-r--r--meta-agl-lxc/conf/multiconfig/agl-container-ivi.conf14
-rw-r--r--meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb2
-rw-r--r--templates/feature/agl-lxc/50_local.conf.inc2
5 files changed, 42 insertions, 7 deletions
diff --git a/meta-agl-lxc/conf/multiconfig/agl-container-cluster.conf b/meta-agl-lxc/conf/multiconfig/agl-container-cluster.conf
new file mode 100644
index 00000000..29272c78
--- /dev/null
+++ b/meta-agl-lxc/conf/multiconfig/agl-container-cluster.conf
@@ -0,0 +1,29 @@
+# The aglcontainerguest is a common keyword for agl container.
+OVERRIDES:append = ":aglcontainerguest"
+
+# The aglcontainercluster is specific keyword for cluster guest.
+OVERRIDES:append = ":aglcontainercluster"
+
+TMPDIR = "${TOPDIR}/tmp-${BB_CURRENT_MC}"
+
+# Can be blank as container image type results in a .tar.bz2
+AGL_DEFAULT_IMAGE_FSTYPES = ""
+AGL_EXTRA_IMAGE_FSTYPES = ""
+
+IMAGE_FSTYPES:aglcontainerguest = "container"
+
+IMAGE_LINGUAS:append:aglcontainercluster = " en-us"
+
+PREFERRED_PROVIDER_virtual/kernel:aglcontainerguest = "linux-dummy"
+KERNEL_DEVICETREE:aglcontainercluster = ""
+
+# Disable serial consoles
+SERIAL_CONSOLES:aglcontainerguest = ""
+
+# Remove unneeded firmware packages
+EXTRA_IMAGEDEPENDS:remove:aglcontainerguest = "arm-trusted-firmware optee-os u-boot"
+
+# We assume rngd is running on the host, so unnecessary in container
+VIRTUAL-RUNTIME_rngd = ""
+
+hostname:append:aglcontainercluster = "-cluster"
diff --git a/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf b/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf
index cf5320e9..db25b3b7 100644
--- a/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf
+++ b/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf
@@ -10,7 +10,7 @@ IMAGE_FSTYPES:aglcontainerguest = "container"
IMAGE_LINGUAS:append:aglcontainerguest = " en-us"
-PREFERRED_PROVIDER_virtual/kernel_aglcontainerguest = "linux-dummy"
+PREFERRED_PROVIDER_virtual/kernel:aglcontainerguest = "linux-dummy"
KERNEL_DEVICETREE:aglcontainerguest = ""
# Disable serial consoles
diff --git a/meta-agl-lxc/conf/multiconfig/agl-container-ivi.conf b/meta-agl-lxc/conf/multiconfig/agl-container-ivi.conf
index d5bc5c41..08dc9935 100644
--- a/meta-agl-lxc/conf/multiconfig/agl-container-ivi.conf
+++ b/meta-agl-lxc/conf/multiconfig/agl-container-ivi.conf
@@ -1,3 +1,7 @@
+# The aglcontainerguest is a common keyword for agl container.
+OVERRIDES_append = ":aglcontainerguest"
+
+# The aglcontainerivi is specific keyword for ivi guest.
OVERRIDES:append = ":aglcontainerivi"
TMPDIR = "${TOPDIR}/tmp-${BB_CURRENT_MC}"
@@ -6,18 +10,20 @@ TMPDIR = "${TOPDIR}/tmp-${BB_CURRENT_MC}"
AGL_DEFAULT_IMAGE_FSTYPES:aglcontainerivi = ""
AGL_EXTRA_IMAGE_FSTYPES:aglcontainerivi = ""
-IMAGE_FSTYPES:aglcontainerivi = "container"
+IMAGE_FSTYPES:aglcontainerguest = "container"
IMAGE_LINGUAS:append:aglcontainerivi = " en-us"
-PREFERRED_PROVIDER_virtual/kernel_aglcontainerguest = "linux-dummy"
+PREFERRED_PROVIDER_virtual/kernel:aglcontainerguest = "linux-dummy"
KERNEL_DEVICETREE:aglcontainerivi = ""
# Disable serial consoles
-SERIAL_CONSOLES:aglcontainerivi = ""
+SERIAL_CONSOLES:aglcontainerguest = ""
# Remove unneeded firmware packages
-EXTRA_IMAGEDEPENDS:remove:aglcontainerivi = "arm-trusted-firmware optee-os u-boot"
+EXTRA_IMAGEDEPENDS:remove:aglcontainerguest = "arm-trusted-firmware optee-os u-boot"
# We assume rngd is running on the host, so unnecessary in container
VIRTUAL-RUNTIME_rngd = ""
+
+hostname:append:aglcontainerivi = "-ivi"
diff --git a/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb b/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
index b109b1fc..fd7e559b 100644
--- a/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
+++ b/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
@@ -3,7 +3,7 @@ LICENSE = "MIT"
require lxc-host-image-minimal.bb
-CONTAINER_IMAGES ?= "agl-container-guest:guest-image-cluster-demo \
+CONTAINER_IMAGES ?= "agl-container-cluster:guest-image-cluster-demo \
agl-container-ivi:guest-image-ivi-demo \
"
diff --git a/templates/feature/agl-lxc/50_local.conf.inc b/templates/feature/agl-lxc/50_local.conf.inc
index 317937bf..dce87a49 100644
--- a/templates/feature/agl-lxc/50_local.conf.inc
+++ b/templates/feature/agl-lxc/50_local.conf.inc
@@ -1,4 +1,4 @@
-BBMULTICONFIG = "agl-container-guest agl-container-ivi"
+BBMULTICONFIG = "agl-container-cluster agl-container-ivi"
# The meta-virtualization has a sanity-meta-virt check.
# This checker check 'DISTRO_FEATURES has virtualization', but