summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-11-08 01:15:43 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-16 20:38:05 +0000
commit65a6faad356f3e4072eabedd4da438373793cd3a (patch)
tree55af662fcde289280023ce328a7dab91abbf211a
parent39ed7563490002e59e4d69136ce87aea20fc1000 (diff)
Fix recipe style error at momiplay recipe
The bitbake recipe has style guide at https://www.openembedded.org/wiki/Styleguide Existing momiplay recipe does not fit this style guide. This patch fix this issue. Bug-AGL: SPEC-4094 Change-Id: Icb28faa991c8dd66807fcaadac77318c66dd77aa Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb36
1 files changed, 24 insertions, 12 deletions
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb b/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
index 94e4afc6..25674fbc 100644
--- a/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
+++ b/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
@@ -4,14 +4,17 @@ DESCRIPTION = "The momiplay is a mediaplayer example based on AGL sample app. \
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=17;md5=f4ad6901289f57f62d15bfefb5cc3633"
-PV = "0.2.0"
-
-inherit qmake5 systemd
+DEPENDS = " \
+ qtbase \
+ qtquickcontrols2 \
+ qtgraphicaleffects \
+ qtsvg \
+ qtmultimedia \
+ "
-DEPENDS = "qtbase qtquickcontrols2 qtgraphicaleffects qtsvg qtmultimedia "
-RDEPENDS_${PN} = "qtsvg qtmultimedia "
+PV = "0.2.0"
-SRC_URI = "git://github.com/AGLExport/momiplayer.git;protocol=https \
+SRC_URI = "git://github.com/AGLExport/momiplayer.git;protocol=https;branch=master \
file://momiplay.service \
file://momiplay \
"
@@ -19,13 +22,11 @@ SRCREV = "b4715bf924ea295feaaf8fbdb4a9c3da75f57591"
S = "${WORKDIR}/git"
-QT_INSTALL_PREFIX = "/usr"
+inherit qmake5 systemd
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "momiplay.service"
-SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+QT_INSTALL_PREFIX = "/usr"
-do_install_append() {
+do_install:append() {
install -d ${D}/lib/systemd/system
install -m 0644 ${WORKDIR}/momiplay.service ${D}/lib/systemd/system
@@ -33,4 +34,15 @@ do_install_append() {
install -m 0755 ${WORKDIR}/momiplay ${D}${sysconfdir}/default/
}
-FILES_${PN} += " ${systemd_unitdir} ${sysconfdir}/*/* "
+FILES:${PN} += " \
+ ${systemd_unitdir} \
+ ${sysconfdir}/*/* \
+ "
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "momiplay.service"
+SYSTEMD_AUTO_ENABLE:${PN} = "disable"
+
+RDEPENDS:${PN} = " \
+ qtsvg \
+ qtmultimedia \
+ "