summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-07 07:07:47 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-01 20:10:23 +0000
commitbd307b1c87c8137cbfebf1162b981bbfa49158e3 (patch)
tree8fc175df155e160753e0da651acfb32341b897a4
parent8f4d303b74bb07d6787c5292e862588a2f6cb411 (diff)
Fix multiple container installation issue
When I build lxc-host-image-demo, that out error message; Nothing RPROVIDES 'lxc-config-cluster-demolxc-config-ivi-demo' (but ~/meta-agl-devel/meta-agl-lxc/recipes-platform/images/ lxc-host-image-demo.bb RDEPENDS on or otherwise requires it) The 'lxc-config-cluster-demolxc-config-ivi-demo' is must describe to 'lxc-config-cluster-demo lxc-config-ivi-demo', that need space between image name and image name. This patch fix this issue. Bug-AGL: SPEC-4109 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: I3e3f057264c0e05872a1f04f9bf5c72af54115e1
-rw-r--r--meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb b/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
index 912d868a..f9c17448 100644
--- a/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
+++ b/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
@@ -28,7 +28,7 @@ python __anonymous() {
config = image
if config.startswith('guest-image-'):
config = config[len('guest-image-'):]
- d.appendVar('LXC_CONTAINER_CONFIGS', 'lxc-config-' + config)
+ d.appendVar('LXC_CONTAINER_CONFIGS', ' ' + 'lxc-config-' + config)
}
install_container_images() {