summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-06-14 16:06:30 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-06-15 15:46:41 +0000
commitccfac6e024b1404d9c9e59455bf58454533e8e51 (patch)
tree51331952fac48e0caee077356069b480b10a4fd4
parent1f9f960298a6a2e6ae0360c4ef42e88c9678069a (diff)
Feature cleanup for Nifty Needlefish
Remove features with upstream deprecated or unmaintained: - meta-ros - agl-service-alexa and the voiceagent service Bug-AGL: SPEC-4407 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I8a1e3886897af5b2cf591d0952b1feb980b8708e
-rw-r--r--meta-agl-ros2/conf/layer.conf12
-rw-r--r--meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros-native-qt5.bb27
-rw-r--r--meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-minimal.bb81
-rw-r--r--meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-ydlidar.bb14
-rw-r--r--meta-agl-ros2/recipes-ros2/ydlidar-ros2-driver/ydlidar-ros2-driver_1.0.1.bb62
-rw-r--r--meta-agl-ros2/recipes-ros2/ydlidar-ros2-sdk/ydlidar-ros2-sdk_1.4.7.bb24
-rw-r--r--templates/feature/agl-ros2/50_bblayers.conf.inc17
-rw-r--r--templates/feature/agl-ros2/50_local.conf.inc8
-rw-r--r--templates/feature/agl-ros2/README_feature_agl-ros2.md8
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc6
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc1
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/50_setup.sh45
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md15
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch31
-rw-r--r--templates/feature/agl-voiceagent-alexa-wakeword/included.dep1
-rw-r--r--templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc15
-rw-r--r--templates/feature/agl-voiceagent-alexa/50_local.conf.inc2
-rw-r--r--templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md8
18 files changed, 0 insertions, 377 deletions
diff --git a/meta-agl-ros2/conf/layer.conf b/meta-agl-ros2/conf/layer.conf
deleted file mode 100644
index c616d800..00000000
--- a/meta-agl-ros2/conf/layer.conf
+++ /dev/null
@@ -1,12 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH =. "${LAYERDIR}:"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "aglros2"
-BBFILE_PATTERN_aglros2 = "^${LAYERDIR}/"
-BBFILE_PRIORITY_aglros2 = "70"
-
-LAYERSERIES_COMPAT_aglros2 = "kirkstone" \ No newline at end of file
diff --git a/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros-native-qt5.bb b/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros-native-qt5.bb
deleted file mode 100644
index 28e3976b..00000000
--- a/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros-native-qt5.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "Qt5 for native GUI framework of AGL IVI profile"
-DESCRIPTION = "A set of Qt5 packages which required by Native App Fw Subsystem"
-
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-ros-native-qt5 \
- "
-
-RDEPENDS:${PN} += "\
- qtbase \
- qtbase-dev \
- qtbase-plugins \
- qtbase-staticdev \
- qtbase-tools \
- qtdeclarative \
- qtdeclarative-qmlplugins \
- qtdeclarative-tools \
- qtcharts \
- qtwayland \
- qtwayland-plugins \
- qtwayland-tools \
- qtgraphicaleffects-qmlplugins \
- qtvirtualkeyboard \
- " \ No newline at end of file
diff --git a/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-minimal.bb b/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-minimal.bb
deleted file mode 100644
index 0644ec5c..00000000
--- a/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-minimal.bb
+++ /dev/null
@@ -1,81 +0,0 @@
-DESCRIPTION = "The minimal set of packages required to ROS2"
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-ros2-minimal \
- "
-
-RDEPENDS:${PN} += " \
- action-msgs \
- ament-cmake \
- ament-index-cpp \
- ament-index-python \
- ament-package \
- builtin-interfaces \
- class-loader \
- composition-interfaces \
- console-bridge-vendor \
- fastrtps \
- foonathan-memory-vendor \
- geometry-msgs \
- launch \
- launch-ros \
- libstatistics-collector \
- libyaml-vendor \
- lifecycle-msgs \
- message-filters \
- osrf-pycommon \
- rcl \
- rcl-action \
- rcl-interfaces \
- rcl-logging-spdlog \
- rcl-yaml-param-parser \
- rclcpp \
- rclcpp-action \
- rclcpp-components \
- rclpy \
- rcpputils \
- rcutils \
- rmw \
- rmw-dds-common \
- rmw-fastrtps-cpp \
- rmw-fastrtps-shared-cpp \
- rmw-implementation \
- rmw-implementation-cmake \
- ros-workspace \
- ros2cli \
- ros2launch \
- ros2pkg \
- ros2topic \
- rosgraph-msgs \
- rosidl-adapter \
- rosidl-cmake \
- rosidl-default-runtime \
- rosidl-generator-c \
- rosidl-generator-py \
- rosidl-parser \
- rosidl-runtime-c \
- rosidl-runtime-cpp \
- rosidl-runtime-py \
- rosidl-typesupport-c \
- rosidl-typesupport-cpp \
- rosidl-typesupport-fastrtps-c \
- rosidl-typesupport-fastrtps-cpp \
- rosidl-typesupport-interface \
- rosidl-typesupport-introspection-c \
- rosidl-typesupport-introspection-cpp \
- rpyutils \
- sensor-msgs \
- spdlog-vendor \
- statistics-msgs \
- std-msgs \
- std-srvs \
- tf2 \
- tf2-msgs \
- tf2-py \
- tf2-ros \
- unique-identifier-msgs \
- visualization-msgs \
- " \ No newline at end of file
diff --git a/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-ydlidar.bb b/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-ydlidar.bb
deleted file mode 100644
index a066e85a..00000000
--- a/meta-agl-ros2/recipes-platform/packagegroups/packagegroup-agl-ros2-ydlidar.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "Support of ydlidar with ROS2"
-LICENSE = "MIT"
-
-inherit packagegroup
-
-PACKAGES = "\
- packagegroup-agl-ros2-ydlidar \
- "
-
-ALLOW_EMPTY:${PN} = "1"
-
-RDEPENDS:${PN} += " \
- ydlidar-ros2-driver \
- " \ No newline at end of file
diff --git a/meta-agl-ros2/recipes-ros2/ydlidar-ros2-driver/ydlidar-ros2-driver_1.0.1.bb b/meta-agl-ros2/recipes-ros2/ydlidar-ros2-driver/ydlidar-ros2-driver_1.0.1.bb
deleted file mode 100644
index cff912d0..00000000
--- a/meta-agl-ros2/recipes-ros2/ydlidar-ros2-driver/ydlidar-ros2-driver_1.0.1.bb
+++ /dev/null
@@ -1,62 +0,0 @@
-inherit ros_distro_foxy
-inherit ros_superflore_generated
-
-SUMMARY = "YDLIDAR"
-DESCRIPTION = "YDLIDAR driver recipe for ROS2 support."
-AUTHOR = "Shankho Boron Ghosh"
-ROS_AUTHOR = "Shankho Boron Ghosh"
-HOMEPAGE = "https://wiki.ros.org"
-SECTION = "devel"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d41d8cd98f00b204e9800998ecf8427e"
-
-ROS_CN = "ydlidar_ros2_driver"
-ROS_BPN = "ydlidar_ros2_driver"
-
-ROS_BUILD_DEPENDS = " \
- rclcpp \
- rclcpp-components \
- sensor-msgs \
- visualization-msgs \
- geometry-msgs \
- std-srvs \
-"
-
-ROS_BUILDTOOL_DEPENDS = " \
- ament-cmake-auto-native \
- ament-cmake-ros-native \
-"
-
-ROS_EXPORT_DEPENDS = ""
-
-ROS_BUILDTOOL_EXPORT_DEPENDS = ""
-
-ROS_EXEC_DEPENDS = " \
- rclcpp \
- rclcpp-components \
- sensor-msgs \
- visualization-msgs \
- geometry-msgs \
- std-srvs \
-"
-
-# Currently informational only -- see http://www.ros.org/reps/rep-0149.html#dependency-tags.
-ROS_TEST_DEPENDS = ""
-
-DEPENDS = "${ROS_BUILD_DEPENDS} ${ROS_BUILDTOOL_DEPENDS}"
-# Bitbake doesn't support the "export" concept, so build them as if we needed them to build this package (even though we actually
-# don't) so that they're guaranteed to have been staged should this package appear in another's DEPENDS.
-DEPENDS += "${ROS_EXPORT_DEPENDS} ${ROS_BUILDTOOL_EXPORT_DEPENDS}"
-#added
-DEPENDS += "ydlidar-ros2-sdk"
-
-RDEPENDS:${PN} += "${ROS_EXEC_DEPENDS}"
-
-#ROS_BRANCH ?= "branch=release/foxy/ydlidar_ros2_driver"
-SRC_URI = "git://github.com/YDLIDAR/ydlidar_ros2_driver;branch=master;protocol=https"
-SRCREV = "2e095da315aec0a0bc5aaac12082cb9d1f97f8b5"
-S = "${WORKDIR}/git"
-
-ROS_BUILD_TYPE = "ament_cmake"
-
-inherit ros_${ROS_BUILD_TYPE} \ No newline at end of file
diff --git a/meta-agl-ros2/recipes-ros2/ydlidar-ros2-sdk/ydlidar-ros2-sdk_1.4.7.bb b/meta-agl-ros2/recipes-ros2/ydlidar-ros2-sdk/ydlidar-ros2-sdk_1.4.7.bb
deleted file mode 100644
index db01372f..00000000
--- a/meta-agl-ros2/recipes-ros2/ydlidar-ros2-sdk/ydlidar-ros2-sdk_1.4.7.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-SUMMARY = "YDLIDAR-SDK"
-DESCRIPTION = "YDLIDAR-SDK as it a dependency for ydlidar_ros2_driver."
-AUTHOR = "Shankho Boron Ghosh"
-ROS_AUTHOR = "Shankho Boron Ghosh"
-HOMEPAGE = "https://github.com/YDLIDAR/YDLIDAR/YDLidar-SDK"
-SECTION = "devel"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4e320231d59c825e45dbfda066af29c9"
-
-SRC_URI = "git://github.com/YDLIDAR/YDLidar-SDK.git;protocol=https;branch=master"
-
-SRCREV = "8b287ed831db0892f51793650b438790442fa09c"
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-FILES:${PN} += "${datadir} ${prefix}/startup"
-
-do_install:append() {
- sed -i -e 's|${DEBUG_PREFIX_MAP}||g; s|--sysroot=${STAGING_DIR_TARGET}||g' ${D}${libdir}/pkgconfig/*.pc
-}
-
-RDEPENDS:${PN} += "bash" \ No newline at end of file
diff --git a/templates/feature/agl-ros2/50_bblayers.conf.inc b/templates/feature/agl-ros2/50_bblayers.conf.inc
deleted file mode 100644
index 4f011f86..00000000
--- a/templates/feature/agl-ros2/50_bblayers.conf.inc
+++ /dev/null
@@ -1,17 +0,0 @@
-# agl-ros2
-
-# Layer dependencies for meta-ros2
-# Add meta-ros layers : https://growupboron.github.io/blog/gsoc-weekly-update-week-2/
-# Add ydlidar-drivers : https://growupboron.github.io/blog/gsoc-weekly-update-week-4/
-
-AGL_META_PYTHON = "${METADIR}/external/meta-openembedded/meta-python"
-
-BBLAYERS =+ " \
- ${METADIR}/external/meta-ros/meta-ros-common \
- ${METADIR}/external/meta-ros/meta-ros-backports-gatesgarth \
- ${METADIR}/external/meta-ros/meta-ros-backports-hardknott \
- ${METADIR}/external/meta-ros/meta-ros2 \
- ${METADIR}/external/meta-ros/meta-ros2-foxy \
- ${METADIR}/external/meta-qt5 \
- ${METADIR}/meta-agl-devel/meta-agl-ros2 \
- " \ No newline at end of file
diff --git a/templates/feature/agl-ros2/50_local.conf.inc b/templates/feature/agl-ros2/50_local.conf.inc
deleted file mode 100644
index 4ffa2cd1..00000000
--- a/templates/feature/agl-ros2/50_local.conf.inc
+++ /dev/null
@@ -1,8 +0,0 @@
-# agl-ros2
-
-# Contains minimal ros2 feature that is neccesary to run YDLIDAR drivers.
-IMAGE_INSTALL:append = " packagegroup-agl-ros2-minimal"
-IMAGE_INSTALL:append = " packagegroup-agl-ros2-ydlidar"
-
-# Adds Qt support to the built image
-IMAGE_INSTALL:append = " packagegroup-agl-ros-native-qt5" \ No newline at end of file
diff --git a/templates/feature/agl-ros2/README_feature_agl-ros2.md b/templates/feature/agl-ros2/README_feature_agl-ros2.md
deleted file mode 100644
index 8c7eccd5..00000000
--- a/templates/feature/agl-ros2/README_feature_agl-ros2.md
+++ /dev/null
@@ -1,8 +0,0 @@
----
-description: Feature agl-ros2
-authors: Shankho Boron Ghosh <shankhoghosh123@gmail.com>
----
-
-### Feature agl-ros2
-
-Enables building of meta-ros2-foxy layer with additional support for YDLIDAR drivers. \ No newline at end of file
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc b/templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc
deleted file mode 100644
index 31f4dca8..00000000
--- a/templates/feature/agl-voiceagent-alexa-wakeword/50_bblayers.conf.inc
+++ /dev/null
@@ -1,6 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/external/alexa-auto-sdk/extensions/extras/amazonlite/meta-aac-amazonlite \
-"
-
-# Include the recipe for the required module as well
-BBFILES += "${METADIR}/external/alexa-auto-sdk/extensions/extras/amazonlite/modules/*/*.bb"
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc b/templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc
deleted file mode 100644
index 41af3db8..00000000
--- a/templates/feature/agl-voiceagent-alexa-wakeword/50_local.conf.inc
+++ /dev/null
@@ -1 +0,0 @@
-ALEXA_WAKEWORD = "true"
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/50_setup.sh b/templates/feature/agl-voiceagent-alexa-wakeword/50_setup.sh
deleted file mode 100644
index 6e1d2503..00000000
--- a/templates/feature/agl-voiceagent-alexa-wakeword/50_setup.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-# Install and patch Amazon Alexa Auto SDK "amazonlite" wakeword engine
-
-pushd $METADIR >/dev/null 2>&1
-
-WAKEWORD_FEATURE_DIR="$METADIR/meta-agl-devel/templates/feature/agl-voiceagent-alexa-wakeword"
-AMAZONLITE_VER="2.3"
-AMAZONLITE_PATCH="${WAKEWORD_FEATURE_DIR}/amazonlite-${AMAZONLITE_VER}.patch"
-AUTOSDK_EXTRAS_DIR="$METADIR/external/alexa-auto-sdk/extensions/extras"
-AMAZONLITE_DIR="${AUTOSDK_EXTRAS_DIR}/amazonlite"
-
-if [ -f "${AMAZONLITE_DIR}/README.md" ]; then
- ver=`grep '^Unzip the' "${AMAZONLITE_DIR}/README.md" | sed 's/.*amazonlite-\([0-9]\+\.[0-9]\+\)\.zip.*/\1/'`
- if [ "$ver" != ${AMAZONLITE_VER} ]; then
- echo "ERROR: ${AMAZONLITE_DIR} does not contain version ${AMAZONLITE_VER}!" >&2
- exit 1
- fi
-fi
-
-test -f ${XDG_CONFIG_HOME:-~/.config}/user-dirs.dirs && source ${XDG_CONFIG_HOME:-~/.config}/user-dirs.dirs
-DOWNLOAD_DIR=${XDG_DOWNLOAD_DIR:-$HOME/Downloads}
-
-if [ ! -f "${DOWNLOAD_DIR}/amazonlite-${AMAZONLITE_VER}.zip" ]; then
- echo "ERROR: amazonlite-${AMAZONLITE_VER}.zip not found in ${DOWNLOAD_DIR}!" >&2
- exit 1
-elif [ ! -d "${AUTOSDK_EXTRAS_DIR}" ]; then
- echo "ERROR: Directory ${AUTOSDK_EXTRAS_DIR} not present!" >&2
- exit 1
-fi
-cd "${AUTOSDK_EXTRAS_DIR}"
-if [ ! -d amazonlite ]; then
- echo "Extracting ${DOWNLOAD_DIR}/amazonlite-${AMAZONLITE_VER}.zip"
- unzip -q "${DOWNLOAD_DIR}/amazonlite-${AMAZONLITE_VER}.zip" || exit 1
- cd amazonlite
- echo "Patching ${AMAZONLITE_DIR}"
- patch -p0 < "${AMAZONLITE_PATCH}"
-else
- cat <<-EOF
-The amazonlite ${AMAZONLITE_VER} wakeword engine is already installed.
-To force reinstallation, manually remove the directory:
- ${AMAZONLITE_DIR}
-
-EOF
-fi
-
-popd >/dev/null 2>&1
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md b/templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md
deleted file mode 100644
index 4917a96f..00000000
--- a/templates/feature/agl-voiceagent-alexa-wakeword/README_feature_agl-voiceagent-alexa-wakeword.md
+++ /dev/null
@@ -1,15 +0,0 @@
----
-description: Feature agl-voiceagent-alexa-wakeword
-authors: Scott Murray <scott.murray@konsulko.com>
----
-
-### Feature agl-voiceagent-alexa-wakeword
-
-Enables building the Amazon Alexa voiceagent binding with included wakeword engine support.
-
-Note that this features assumes that the amazonlite wakeword engine ZIP file
-(i.e. amazonlite-2.3.zip) is present in the directory pointed at by the
-XDG_DOWNLOAD_DIR environment variable if it is set, and $HOME/Downloads
-otherwise. The zip file will be extracted into place in the alexa-auto-sdk
-repository (at external/alexa-auto-sdk/extensions/extra/amazonlite), and
-patched to work with the version of Yocto used by AGL.
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch b/templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch
deleted file mode 100644
index ec9975fa..00000000
--- a/templates/feature/agl-voiceagent-alexa-wakeword/amazonlite-2.3.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- meta-aac-amazonlite/recipes-avs/avs-device-sdk/avs-device-sdk_%.bbappend.bak 2021-02-01 16:41:34.464564753 -0500
-+++ meta-aac-amazonlite/recipes-avs/avs-device-sdk/avs-device-sdk_%.bbappend 2021-02-01 16:41:54.392457938 -0500
-@@ -3,6 +3,8 @@
-
- SRC_URI += "file://${AMAZONLITE_PACKAGES}/${WRAPPER_NAME}-${WRAPPER_VERSION}.tgz"
-
-+inherit python3native
-+
- AMAZONLITE_CPP_MODEL_NAME ?= "D.en-US.alexa.cpp"
- AMAZONLITE_CPP_MODEL_PATH = "${STAGING_DIR_HOST}${datadir}/pryon-lite/models"
-
-@@ -19,5 +21,5 @@
- PACKAGECONFIG += "amazonlite"
-
- do_configure_prepend() {
-- ${WORKDIR}/${WRAPPER_NAME}/apply_adapter.py ${S}
--}
-\ No newline at end of file
-+ ${PYTHON} ${WORKDIR}/${WRAPPER_NAME}/apply_adapter.py ${S}
-+}
---- meta-aac-amazonlite/conf/layer.conf.bak 2021-02-01 17:44:07.559285446 -0500
-+++ meta-aac-amazonlite/conf/layer.conf 2021-02-01 17:44:42.847875916 -0500
-@@ -9,6 +9,8 @@
- BBFILE_PATTERN_aac-amazonlite = "^${LAYERDIR}/"
- BBFILE_PRIORITY_aac-amazonlite = "6"
-
-+LAYERSERIES_COMPAT_aac-amazonlite = "kirkstone"
-+
- AMAZONLITE ?= "ON"
- AMAZONLITE_PACKAGES = "${LAYERDIR}/packages"
-
diff --git a/templates/feature/agl-voiceagent-alexa-wakeword/included.dep b/templates/feature/agl-voiceagent-alexa-wakeword/included.dep
deleted file mode 100644
index 71688dda..00000000
--- a/templates/feature/agl-voiceagent-alexa-wakeword/included.dep
+++ /dev/null
@@ -1 +0,0 @@
-agl-voiceagent-alexa
diff --git a/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc b/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc
deleted file mode 100644
index 94d877ae..00000000
--- a/templates/feature/agl-voiceagent-alexa/50_bblayers.conf.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-BBLAYERS =+ " \
- ${METADIR}/meta-agl-devel/meta-speech-framework \
- ${METADIR}/external/alexa-auto-sdk/builder/meta-aac \
-"
-
-# Per the SDK documentation, the module recipes need to be manually
-# added, as they sit outside of the layer.
-BBFILES += "${METADIR}/external/alexa-auto-sdk/modules/*/*.bb"
-
-# Include the recipe for the required gstreamer module as well
-BBFILES += "${METADIR}/external/alexa-auto-sdk/extensions/experimental/system-audio/modules/*/*.bb"
-
-# For now, tweak the layer's compatibility to allow using with zeus,
-# since we know it works without major issues.
-LAYERSERIES_COMPAT_aac:append = " kirkstone"
diff --git a/templates/feature/agl-voiceagent-alexa/50_local.conf.inc b/templates/feature/agl-voiceagent-alexa/50_local.conf.inc
deleted file mode 100644
index 828b88d6..00000000
--- a/templates/feature/agl-voiceagent-alexa/50_local.conf.inc
+++ /dev/null
@@ -1,2 +0,0 @@
-#see meta-agl-devel/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
-require conf/include/agl-voiceagent-alexa.inc
diff --git a/templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md b/templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md
deleted file mode 100644
index 584042fe..00000000
--- a/templates/feature/agl-voiceagent-alexa/README_feature_agl-voiceagent-alexa.md
+++ /dev/null
@@ -1,8 +0,0 @@
----
-description: Feature agl-voiceagent-alexa
-authors: Scott Murray <scott.murray@konsulko.com>
----
-
-### Feature agl-voiceagent-alexa
-
-Enables building Amazon Alexa voice agent binding for the speech framework using the Alexa Automotive SDK.