summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-05-13 14:41:41 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-13 10:47:39 +0000
commiteb1cb6e454c2355d64238683d2111f5da4964706 (patch)
tree7fd4f2a22d1c085cf947be90379afdddbe9da028
parent9e91874e6e23eb36570653aaf93e0d4d994d90bc (diff)
Replace "/etc" with "${sysconfidir}"
make them more standardized v2: also update ${D}/lib -> ${D}${libdir} v3: updated FILES sections as well Bug-AGL: SPEC-4374 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: Ia2809d849ba9424aa54bab5b651c07b24d3a5cee
-rw-r--r--meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb4
-rw-r--r--meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb10
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb12
3 files changed, 13 insertions, 13 deletions
diff --git a/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb b/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb
index cd34dc75..0714f62b 100644
--- a/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb
+++ b/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb
@@ -9,11 +9,11 @@ SRC_URI = " \
"
do_install() {
- install -D -m0644 ${WORKDIR}/20-wired.network ${D}/etc/systemd/network/20-wired.network
+ install -D -m0644 ${WORKDIR}/20-wired.network ${D}${sysconfdir}/systemd/network/20-wired.network
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILES:${PN} = "\
- /etc/systemd/network/* \
+ ${sysconfdir}/systemd/network/* \
"
diff --git a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
index 209cd978..2f976b39 100644
--- a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
+++ b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
@@ -19,13 +19,13 @@ inherit autotools pkgconfig systemd
do_install:append() {
#install scripts
- install -d ${D}/etc
- install -m 0644 ${WORKDIR}/agl.json ${D}/etc
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/agl.json ${D}${sysconfdir}
- install -d ${D}/lib/systemd/system
- install -m 0644 ${WORKDIR}/ilm-manager.service ${D}/lib/systemd/system
+ install -d ${D}/${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/ilm-manager.service ${D}${systemd_system_unitdir}
}
-FILES:${PN} += " ${systemd_unitdir} /etc/* "
+FILES:${PN} += " ${systemd_system_unitdir} ${sysconfdir} "
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} = "ilm-manager.service"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb
index a918ee0b..39f6902d 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb
@@ -14,10 +14,10 @@ do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
- install -d ${D}/etc/systemd/system/
- install -m 644 ${S}/launch_sm.service ${D}/etc/systemd/system/
- install -m 644 ${S}/systemd-udev-trigger.service ${D}/etc/systemd/system/
- install -m 644 ${S}/setup_refhw.service ${D}/etc/systemd/system/
+ install -d ${D}${sysconfdir}/systemd/system/
+ install -m 644 ${S}/launch_sm.service ${D}${sysconfdir}/systemd/system/
+ install -m 644 ${S}/systemd-udev-trigger.service ${D}${sysconfdir}/systemd/system/
+ install -m 644 ${S}/setup_refhw.service ${D}${sysconfdir}/systemd/system/
install -d ${D}${CONFDIR}/
install -m 644 ${S}/env.txt ${D}${CONFDIR}/
@@ -25,8 +25,8 @@ do_install() {
install -d ${D}${bindir}
install -m 755 ${S}/tool_9E_SI/*.sh ${D}${bindir}/
- install -d ${D}/lib/udev/rules.d
- install -m 644 ${S}/99-basesystem.rules ${D}/lib/udev/rules.d/
+ install -d ${D}${libdir}/udev/rules.d
+ install -m 644 ${S}/99-basesystem.rules ${D}/${libdir}/udev/rules.d/
}
RDEPENDS:${PN} += "bash"