summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-10-13 14:40:31 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-16 11:40:24 +0000
commit00fd6f47a11bf6f9fc7270ce9953af4e22bbb077 (patch)
treea4f78ff8d80ec6445e2575236217c3e503e77143
parentb8c8164076d1a02a8c76fab18506e46223ca6368 (diff)
Remove HTML5 guest support from momiweb
HTML5 demo IVI support was dropped in AGL IVI demo. But that guest support was not removed completely. This patch remove HTML5 demo IVI support from momiweb Bug-AGL: SPEC-5262 Change-Id: I0f48b0df0020c4b51419f3fe0e88cb2a0724defa Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
-rw-r--r--meta-agl-ic-container/recipes-demo/momiweb/files/momiweb.conf4
-rw-r--r--meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/meta-agl-ic-container/recipes-demo/momiweb/files/momiweb.conf b/meta-agl-ic-container/recipes-demo/momiweb/files/momiweb.conf
index 0343867e..e1ad514a 100644
--- a/meta-agl-ic-container/recipes-demo/momiweb/files/momiweb.conf
+++ b/meta-agl-ic-container/recipes-demo/momiweb/files/momiweb.conf
@@ -8,3 +8,7 @@ alias.url = ( "/cgi-bin" => "/www/cgi-bin" )
$HTTP["url"] =~ "^/cgi-bin" {
cgi.assign = ( ".cgi" => "/bin/sh")
}
+setenv.set-response-header = (
+ "x-content-type-options" => "nosniff",
+)
+mimetype.assign += ( ".svg" => "image/svg+xml" )
diff --git a/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb b/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb
index 0de33dd9..b95240ac 100644
--- a/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb
+++ b/meta-agl-ic-container/recipes-demo/momiweb/momiweb_git.bb
@@ -5,10 +5,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
PV = "0.1.0"
-SRC_URI = "git://github.com/agl-ic-eg/momiweb.git;protocol=https;branch=main \
+SRC_URI = "git://github.com/agl-ic-eg/momiweb.git;protocol=https;branch=agl-master \
file://momiweb.conf \
"
-SRCREV = "cfdfdd670a83558a408bafa7b0262381313b907d"
+SRCREV = "e720ea92df37da05ba33fc7abb4c4822f58dbcf1"
S = "${WORKDIR}/git"