summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYan <yanxk.fnst@fujitsu.com>2023-10-11 09:35:27 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-16 11:45:14 +0000
commit0bd14b0af2f8e6751c39899cf8f9fe42e1960b39 (patch)
tree00a724189a90f182420b1702c7a11e36d1fdbacf
parent675f3f79e39be402065fb6c9fcfba2a9f5693a0a (diff)
agl-wireless-monitor: add MJPG streamer
a new component of the monitor called MJPG streamer is added. Bug-AGL: SPEC-4838 Signed-off-by: Yan <yanxk.fnst@fujitsu.com> Change-Id: I300e50d3f9c803c95de9b620318dbf26d597f6b3
-rw-r--r--meta-agl-wireless-monitor/recipes-component/mjpg_streamer/mjpg-streamer.bb32
-rw-r--r--meta-agl-wireless-monitor/recipes-core/incar-wireless-monitor/incar-wireless-monitor.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-agl-wireless-monitor/recipes-component/mjpg_streamer/mjpg-streamer.bb b/meta-agl-wireless-monitor/recipes-component/mjpg_streamer/mjpg-streamer.bb
new file mode 100644
index 00000000..6c3685b6
--- /dev/null
+++ b/meta-agl-wireless-monitor/recipes-component/mjpg_streamer/mjpg-streamer.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Motion JPEG streamer but modified for AGL system."
+HOMEPAGE = "http://sourceforge.net/projects/mjpg-streamer/"
+DESCRIPTION = "Motion JPEG streamer is a video streamer specially designed for Web Cameras."
+
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://${S}/mjpg-streamer/LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+PN = "mjpg-streamer"
+
+SRC_URI = "git://github.com/lucky33newman/Motion-JPEG-for-AGL.git;branch=main;protocol=https"
+
+SRCREV = "09185f3d55b7c4de6d196d2ad5c5b4eadc4f340a"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libjpeg-turbo"
+RDEPENDS:${PN} += "libjpeg-turbo"
+
+EXTRA_OEMAKE = "LDFLAGS='${LDFLAGS}'"
+
+do_compile() {
+ oe_runmake -C ${S}/mjpg-streamer
+}
+
+do_install() {
+ install -d ${D}/usr/bin/
+ install -m 0755 ${S}/mjpg-streamer/mjpg_streamer ${D}/usr/bin/
+ install -d ${D}/usr/lib/mjpg-streamer
+ install -m 0755 ${S}/mjpg-streamer/*.so ${D}/usr/lib/mjpg-streamer/
+ install -d ${D}/etc/MJPG-streamer/www/
+ install -m 0755 ${S}/mjpg-streamer/www/* ${D}/etc/MJPG-streamer/www/
+}
diff --git a/meta-agl-wireless-monitor/recipes-core/incar-wireless-monitor/incar-wireless-monitor.bb b/meta-agl-wireless-monitor/recipes-core/incar-wireless-monitor/incar-wireless-monitor.bb
index 1fa4dd1d..41726021 100644
--- a/meta-agl-wireless-monitor/recipes-core/incar-wireless-monitor/incar-wireless-monitor.bb
+++ b/meta-agl-wireless-monitor/recipes-core/incar-wireless-monitor/incar-wireless-monitor.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/incar-wireless-monito
SRCREV = "927829c95bac0874b07b0aaee1663f42f5e59530"
RDEPENDS:${PN} += "boa"
+RDEPENDS:${PN} += "mjpg-streamer"
do_install() {
install -d ${D}/etc/boa/www/