summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-11-20 18:09:04 -0500
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-03-20 21:18:38 +0000
commit0cb673b0be1dba0864212f9b562af72c67f7dde5 (patch)
tree8c6b43e20e72004fa38aa1332a09d609d4a77b6b
parent3058f411221cebcd4f97941d8e9a4c7d65a193b1 (diff)
Add Yocto Project langdale release compatibility
Switch to langdale in LAYERSERIES_COMPAT in layer.conf files. Bug-AGL: SPEC-4578 Change-Id: I8de562f78c16be09c16eb3c34c2f92abb5180f92 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-drm-lease/conf/layer.conf2
-rw-r--r--meta-agl-flutter/conf/layer.conf2
-rw-r--r--meta-agl-ic-container/conf/layer.conf2
-rw-r--r--meta-agl-jailhouse/conf/layer.conf2
-rw-r--r--meta-agl-test/conf/layer.conf2
-rw-r--r--meta-egvirt/conf/layer.conf2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf2
-rw-r--r--meta-offline-voice-agent/conf/layer.conf2
8 files changed, 8 insertions, 8 deletions
diff --git a/meta-agl-drm-lease/conf/layer.conf b/meta-agl-drm-lease/conf/layer.conf
index 7614ba9f..8074b6e2 100644
--- a/meta-agl-drm-lease/conf/layer.conf
+++ b/meta-agl-drm-lease/conf/layer.conf
@@ -24,4 +24,4 @@ BBFILES_DYNAMIC += " \
LAYERVERSION_agl-drm-lease = "1"
LAYERDEPENDS_agl-drm-lease = "core"
-LAYERSERIES_COMPAT_agl-drm-lease = "kirkstone"
+LAYERSERIES_COMPAT_agl-drm-lease = "langdale"
diff --git a/meta-agl-flutter/conf/layer.conf b/meta-agl-flutter/conf/layer.conf
index 85cc3aa7..c8071897 100644
--- a/meta-agl-flutter/conf/layer.conf
+++ b/meta-agl-flutter/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PRIORITY_meta-agl-flutter = "61"
LAYERVERSION_meta-agl-flutter = "1"
LAYERDEPENDS_meta-agl-flutter = "core meta-flutter"
-LAYERSERIES_COMPAT_meta-agl-flutter = "kirkstone"
+LAYERSERIES_COMPAT_meta-agl-flutter = "langdale"
diff --git a/meta-agl-ic-container/conf/layer.conf b/meta-agl-ic-container/conf/layer.conf
index ca1bf7a3..9bc9aff0 100644
--- a/meta-agl-ic-container/conf/layer.conf
+++ b/meta-agl-ic-container/conf/layer.conf
@@ -18,5 +18,5 @@ BBFILES_DYNAMIC += " \
selinux:${LAYERDIR}/dynamic-layers/meta-selinux/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_aglcontainermc = "kirkstone"
+LAYERSERIES_COMPAT_aglcontainermc = "kirkstone langdale"
LAYERDEPENDS_aglcontainermc = "aglcore qt5-layer openembedded-layer virtualization-layer agl-drm-lease meta-pipewire"
diff --git a/meta-agl-jailhouse/conf/layer.conf b/meta-agl-jailhouse/conf/layer.conf
index 5dd68b2c..09813b39 100644
--- a/meta-agl-jailhouse/conf/layer.conf
+++ b/meta-agl-jailhouse/conf/layer.conf
@@ -11,7 +11,7 @@ BBFILE_PRIORITY_agl-jailhouse = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-jailhouse = "1"
-LAYERSERIES_COMPAT_agl-jailhouse = "kirkstone"
+LAYERSERIES_COMPAT_agl-jailhouse = "langdale"
# This is only needed for Raspberry Pi
# TODO: can this be expressed dynamically?
diff --git a/meta-agl-test/conf/layer.conf b/meta-agl-test/conf/layer.conf
index f8dba7cb..e197682c 100644
--- a/meta-agl-test/conf/layer.conf
+++ b/meta-agl-test/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PATTERN_agl-test = "^${LAYERDIR}/"
# cause compatibility issues with other layers
LAYERVERSION_agl-test = "1"
-LAYERSERIES_COMPAT_agl-test = "kirkstone"
+LAYERSERIES_COMPAT_agl-test = "langdale"
diff --git a/meta-egvirt/conf/layer.conf b/meta-egvirt/conf/layer.conf
index a8dcafd8..df5554f8 100644
--- a/meta-egvirt/conf/layer.conf
+++ b/meta-egvirt/conf/layer.conf
@@ -11,6 +11,6 @@ BBFILE_PRIORITY_egvirt = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_egvirt = "1"
-LAYERSERIES_COMPAT_egvirt = "kirkstone"
+LAYERSERIES_COMPAT_egvirt = "langdale"
LAYERDEPENDS_egvirt = "core clang-layer filesystems-layer"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
index 10c86f64..5fcc9308 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
+++ b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
@@ -12,5 +12,5 @@ BBFILE_PRIORITY_agl-basesystem = "60"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-basesystem = "1"
-LAYERSERIES_COMPAT_agl-basesystem = "kirkstone"
+LAYERSERIES_COMPAT_agl-basesystem = "langdale"
LAYERDEPENDS_agl-basesystem = "core"
diff --git a/meta-offline-voice-agent/conf/layer.conf b/meta-offline-voice-agent/conf/layer.conf
index e5dca632..4ebbbd20 100644
--- a/meta-offline-voice-agent/conf/layer.conf
+++ b/meta-offline-voice-agent/conf/layer.conf
@@ -10,7 +10,7 @@ BBFILE_PATTERN_meta-offline-voice-agent = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-offline-voice-agent = "65"
LAYERDEPENDS_meta-offline-voice-agent = "core"
-LAYERSERIES_COMPAT_meta-offline-voice-agent = "dunfell kirkstone"
+LAYERSERIES_COMPAT_meta-offline-voice-agent = "langdale"
BBFILES_DYNAMIC += " \
agldemo:${LAYERDIR}/dynamic-layers/meta-agl-demo/*/*/*.bb \