summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-03-19 15:52:49 -0400
committerScott Murray <scott.murray@konsulko.com>2024-03-19 15:52:49 -0400
commit3058f411221cebcd4f97941d8e9a4c7d65a193b1 (patch)
tree74cd35c487f04ea51e371c40d741325cb4147ab9
parente345fe740cbdfee2df76bf9ccfa9300ea5f5bac8 (diff)
meta-agl-flutter: mask out libstd-rs bbappend
The libstd-rs bbappend in meta-flutter breaks building with newer versions of Rust, so BBMASK it out for now. Since the change it makes is to enable debugging Dart/Rust FFI wrappers, and AGL does not currently use such functionality, this should not change any behavior. Bug-AGL: SPEC-5070 Change-Id: I6984303bfc478a7574992f3d927bdaaeb41afa7c Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-flutter/conf/include/agl-flutter.inc4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-flutter/conf/include/agl-flutter.inc b/meta-agl-flutter/conf/include/agl-flutter.inc
index f03adfb2..cf489d02 100644
--- a/meta-agl-flutter/conf/include/agl-flutter.inc
+++ b/meta-agl-flutter/conf/include/agl-flutter.inc
@@ -1,3 +1,7 @@
AGL_FEATURES += "agl-flutter"
FLUTTER_SDK_TAG = "3.13.9"
+
+# Mask libstd-rs bbappend out since the change it makes does not
+# build with newer versions of Rust.
+BBMASK += "meta-flutter/recipes-devtools/rust/libstd-rs_%.bbappend"