summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-09-23 15:16:56 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-03-20 21:18:38 +0000
commit474798c27015b5138d17ab725e3675742c120b3b (patch)
treecf776e993146cc2c0129fff13b1c6c8cd755a313
parent52b11d5b8c285fd219b81c0c261e58b8e9f4b328 (diff)
Add Yocto Project nanbield release compatibility
Switch to nanbield in LAYERSERIES_COMPAT in layer.conf files. Bug-AGL: SPEC-4578 Change-Id: Icf4c4ea12718967b3ae04a3b6cf24d4f8b0f4f4e Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
-rw-r--r--meta-agl-drm-lease/conf/layer.conf2
-rw-r--r--meta-agl-flutter/conf/layer.conf2
-rw-r--r--meta-agl-ic-container/conf/layer.conf2
-rw-r--r--meta-agl-jailhouse/conf/layer.conf2
-rw-r--r--meta-agl-test/conf/layer.conf2
-rw-r--r--meta-agl-wireless-monitor/conf/layer.conf2
-rw-r--r--meta-egvirt/conf/layer.conf2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf2
-rw-r--r--meta-offline-voice-agent/conf/layer.conf2
-rw-r--r--meta-uhmi/meta-rvgpu/conf/layer.conf2
10 files changed, 10 insertions, 10 deletions
diff --git a/meta-agl-drm-lease/conf/layer.conf b/meta-agl-drm-lease/conf/layer.conf
index 1b36bdeb..26d93143 100644
--- a/meta-agl-drm-lease/conf/layer.conf
+++ b/meta-agl-drm-lease/conf/layer.conf
@@ -24,4 +24,4 @@ BBFILES_DYNAMIC += " \
LAYERVERSION_agl-drm-lease = "1"
LAYERDEPENDS_agl-drm-lease = "core"
-LAYERSERIES_COMPAT_agl-drm-lease = "langdale mickledore"
+LAYERSERIES_COMPAT_agl-drm-lease = "langdale mickledore nanbield"
diff --git a/meta-agl-flutter/conf/layer.conf b/meta-agl-flutter/conf/layer.conf
index 6ee02daa..722879b6 100644
--- a/meta-agl-flutter/conf/layer.conf
+++ b/meta-agl-flutter/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PRIORITY_meta-agl-flutter = "61"
LAYERVERSION_meta-agl-flutter = "1"
LAYERDEPENDS_meta-agl-flutter = "core meta-flutter"
-LAYERSERIES_COMPAT_meta-agl-flutter = "langdale mickledore"
+LAYERSERIES_COMPAT_meta-agl-flutter = "langdale mickledore nanbield"
diff --git a/meta-agl-ic-container/conf/layer.conf b/meta-agl-ic-container/conf/layer.conf
index df454775..c88f63f8 100644
--- a/meta-agl-ic-container/conf/layer.conf
+++ b/meta-agl-ic-container/conf/layer.conf
@@ -18,5 +18,5 @@ BBFILES_DYNAMIC += " \
selinux:${LAYERDIR}/dynamic-layers/meta-selinux/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_aglcontainermc = "langdale mickledore"
+LAYERSERIES_COMPAT_aglcontainermc = "langdale mickledore nanbield"
LAYERDEPENDS_aglcontainermc = "aglcore qt5-layer openembedded-layer virtualization-layer agl-drm-lease meta-pipewire"
diff --git a/meta-agl-jailhouse/conf/layer.conf b/meta-agl-jailhouse/conf/layer.conf
index 2196a6d1..e48b8155 100644
--- a/meta-agl-jailhouse/conf/layer.conf
+++ b/meta-agl-jailhouse/conf/layer.conf
@@ -11,7 +11,7 @@ BBFILE_PRIORITY_agl-jailhouse = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-jailhouse = "1"
-LAYERSERIES_COMPAT_agl-jailhouse = "langdale mickledore"
+LAYERSERIES_COMPAT_agl-jailhouse = "langdale mickledore nanbield"
# This is only needed for Raspberry Pi
# TODO: can this be expressed dynamically?
diff --git a/meta-agl-test/conf/layer.conf b/meta-agl-test/conf/layer.conf
index e4fc199b..9e2b59c2 100644
--- a/meta-agl-test/conf/layer.conf
+++ b/meta-agl-test/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PATTERN_agl-test = "^${LAYERDIR}/"
# cause compatibility issues with other layers
LAYERVERSION_agl-test = "1"
-LAYERSERIES_COMPAT_agl-test = "langdale mickledore"
+LAYERSERIES_COMPAT_agl-test = "langdale mickledore nanbield"
diff --git a/meta-agl-wireless-monitor/conf/layer.conf b/meta-agl-wireless-monitor/conf/layer.conf
index 9e4f91b8..0c31d9a7 100644
--- a/meta-agl-wireless-monitor/conf/layer.conf
+++ b/meta-agl-wireless-monitor/conf/layer.conf
@@ -12,4 +12,4 @@ BBFILE_PRIORITY_agl-drm-lease = "100"
# cause compatibility issues with other layers
LAYERVERSION_agl-wireless-monitor = "1"
-LAYERSERIES_COMPAT_agl-wireless-monitor = "kirkstone"
+LAYERSERIES_COMPAT_agl-wireless-monitor = "langdale mickledore nanbield"
diff --git a/meta-egvirt/conf/layer.conf b/meta-egvirt/conf/layer.conf
index 9742f658..100a2df9 100644
--- a/meta-egvirt/conf/layer.conf
+++ b/meta-egvirt/conf/layer.conf
@@ -11,6 +11,6 @@ BBFILE_PRIORITY_egvirt = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_egvirt = "1"
-LAYERSERIES_COMPAT_egvirt = "langdale mickledore"
+LAYERSERIES_COMPAT_egvirt = "langdale mickledore nanbield"
LAYERDEPENDS_egvirt = "core clang-layer filesystems-layer"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
index 1b6e694c..5a203f9e 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
+++ b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
@@ -12,5 +12,5 @@ BBFILE_PRIORITY_agl-basesystem = "60"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-basesystem = "1"
-LAYERSERIES_COMPAT_agl-basesystem = "langdale mickledore"
+LAYERSERIES_COMPAT_agl-basesystem = "langdale mickledore nanbield"
LAYERDEPENDS_agl-basesystem = "core"
diff --git a/meta-offline-voice-agent/conf/layer.conf b/meta-offline-voice-agent/conf/layer.conf
index 7216b854..11fd2855 100644
--- a/meta-offline-voice-agent/conf/layer.conf
+++ b/meta-offline-voice-agent/conf/layer.conf
@@ -10,7 +10,7 @@ BBFILE_PATTERN_meta-offline-voice-agent = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-offline-voice-agent = "65"
LAYERDEPENDS_meta-offline-voice-agent = "core"
-LAYERSERIES_COMPAT_meta-offline-voice-agent = "langdale mickledore"
+LAYERSERIES_COMPAT_meta-offline-voice-agent = "langdale mickledore nanbield"
BBFILES_DYNAMIC += " \
agldemo:${LAYERDIR}/dynamic-layers/meta-agl-demo/*/*/*.bb \
diff --git a/meta-uhmi/meta-rvgpu/conf/layer.conf b/meta-uhmi/meta-rvgpu/conf/layer.conf
index b33aa324..c8dc89e9 100644
--- a/meta-uhmi/meta-rvgpu/conf/layer.conf
+++ b/meta-uhmi/meta-rvgpu/conf/layer.conf
@@ -14,4 +14,4 @@ BBFILES_DYNAMIC += " \
raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_meta-rvgpu= "kirkstone"
+LAYERSERIES_COMPAT_meta-rvgpu= "langdale mickledore nanbield"