summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-06-03 17:00:31 +0000
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-03-20 21:18:38 +0000
commit52b11d5b8c285fd219b81c0c261e58b8e9f4b328 (patch)
treec960de7a589f024d798caf079182ac61687ff59c
parent0cb673b0be1dba0864212f9b562af72c67f7dde5 (diff)
Add Yocto Project mickledore release compatibility
Add mickledore to LAYERSERIES_COMPAT in layer.conf files. Bug-AGL: SPEC-4578 Change-Id: I76d7c5954eded424b9cc11feba046fa80bddccf0 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
-rw-r--r--meta-agl-drm-lease/conf/layer.conf2
-rw-r--r--meta-agl-flutter/conf/layer.conf2
-rw-r--r--meta-agl-ic-container/conf/layer.conf2
-rw-r--r--meta-agl-jailhouse/conf/layer.conf2
-rw-r--r--meta-agl-test/conf/layer.conf2
-rw-r--r--meta-egvirt/conf/layer.conf2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf2
-rw-r--r--meta-offline-voice-agent/conf/layer.conf2
8 files changed, 8 insertions, 8 deletions
diff --git a/meta-agl-drm-lease/conf/layer.conf b/meta-agl-drm-lease/conf/layer.conf
index 8074b6e2..1b36bdeb 100644
--- a/meta-agl-drm-lease/conf/layer.conf
+++ b/meta-agl-drm-lease/conf/layer.conf
@@ -24,4 +24,4 @@ BBFILES_DYNAMIC += " \
LAYERVERSION_agl-drm-lease = "1"
LAYERDEPENDS_agl-drm-lease = "core"
-LAYERSERIES_COMPAT_agl-drm-lease = "langdale"
+LAYERSERIES_COMPAT_agl-drm-lease = "langdale mickledore"
diff --git a/meta-agl-flutter/conf/layer.conf b/meta-agl-flutter/conf/layer.conf
index c8071897..6ee02daa 100644
--- a/meta-agl-flutter/conf/layer.conf
+++ b/meta-agl-flutter/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PRIORITY_meta-agl-flutter = "61"
LAYERVERSION_meta-agl-flutter = "1"
LAYERDEPENDS_meta-agl-flutter = "core meta-flutter"
-LAYERSERIES_COMPAT_meta-agl-flutter = "langdale"
+LAYERSERIES_COMPAT_meta-agl-flutter = "langdale mickledore"
diff --git a/meta-agl-ic-container/conf/layer.conf b/meta-agl-ic-container/conf/layer.conf
index 9bc9aff0..df454775 100644
--- a/meta-agl-ic-container/conf/layer.conf
+++ b/meta-agl-ic-container/conf/layer.conf
@@ -18,5 +18,5 @@ BBFILES_DYNAMIC += " \
selinux:${LAYERDIR}/dynamic-layers/meta-selinux/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_aglcontainermc = "kirkstone langdale"
+LAYERSERIES_COMPAT_aglcontainermc = "langdale mickledore"
LAYERDEPENDS_aglcontainermc = "aglcore qt5-layer openembedded-layer virtualization-layer agl-drm-lease meta-pipewire"
diff --git a/meta-agl-jailhouse/conf/layer.conf b/meta-agl-jailhouse/conf/layer.conf
index 09813b39..2196a6d1 100644
--- a/meta-agl-jailhouse/conf/layer.conf
+++ b/meta-agl-jailhouse/conf/layer.conf
@@ -11,7 +11,7 @@ BBFILE_PRIORITY_agl-jailhouse = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-jailhouse = "1"
-LAYERSERIES_COMPAT_agl-jailhouse = "langdale"
+LAYERSERIES_COMPAT_agl-jailhouse = "langdale mickledore"
# This is only needed for Raspberry Pi
# TODO: can this be expressed dynamically?
diff --git a/meta-agl-test/conf/layer.conf b/meta-agl-test/conf/layer.conf
index e197682c..e4fc199b 100644
--- a/meta-agl-test/conf/layer.conf
+++ b/meta-agl-test/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PATTERN_agl-test = "^${LAYERDIR}/"
# cause compatibility issues with other layers
LAYERVERSION_agl-test = "1"
-LAYERSERIES_COMPAT_agl-test = "langdale"
+LAYERSERIES_COMPAT_agl-test = "langdale mickledore"
diff --git a/meta-egvirt/conf/layer.conf b/meta-egvirt/conf/layer.conf
index df5554f8..9742f658 100644
--- a/meta-egvirt/conf/layer.conf
+++ b/meta-egvirt/conf/layer.conf
@@ -11,6 +11,6 @@ BBFILE_PRIORITY_egvirt = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_egvirt = "1"
-LAYERSERIES_COMPAT_egvirt = "langdale"
+LAYERSERIES_COMPAT_egvirt = "langdale mickledore"
LAYERDEPENDS_egvirt = "core clang-layer filesystems-layer"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
index 5fcc9308..1b6e694c 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
+++ b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
@@ -12,5 +12,5 @@ BBFILE_PRIORITY_agl-basesystem = "60"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-basesystem = "1"
-LAYERSERIES_COMPAT_agl-basesystem = "langdale"
+LAYERSERIES_COMPAT_agl-basesystem = "langdale mickledore"
LAYERDEPENDS_agl-basesystem = "core"
diff --git a/meta-offline-voice-agent/conf/layer.conf b/meta-offline-voice-agent/conf/layer.conf
index 4ebbbd20..7216b854 100644
--- a/meta-offline-voice-agent/conf/layer.conf
+++ b/meta-offline-voice-agent/conf/layer.conf
@@ -10,7 +10,7 @@ BBFILE_PATTERN_meta-offline-voice-agent = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-offline-voice-agent = "65"
LAYERDEPENDS_meta-offline-voice-agent = "core"
-LAYERSERIES_COMPAT_meta-offline-voice-agent = "langdale"
+LAYERSERIES_COMPAT_meta-offline-voice-agent = "langdale mickledore"
BBFILES_DYNAMIC += " \
agldemo:${LAYERDIR}/dynamic-layers/meta-agl-demo/*/*/*.bb \