summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-11-08 18:42:32 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-09 12:55:15 +0000
commit608c0b27cd86588a3989816ffa89a4a6b0bd81b5 (patch)
tree20c91aefa4aff6a84bf00c977752d4b5a23306ca
parentca25ea7efdd08a28a426a7107408524b5a7c18a6 (diff)
flutter-auto: apply Vivante workaround for NXP BSP
Add flutter-auto bbappend back and use it to apply the patch provided in SPEC-4947 when building for NXP BSP platforms that use the Vivante driver. This fixes the crashes observed on imx8mq-evk-viv. Bug-AGL: SPEC-4947 Change-Id: I71786b037f1670e8188d6818a05cb98bc4c129a7 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/0001-Disable-on_frame_base_surface-wl_surface_commit.patch26
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend1
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc3
3 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/0001-Disable-on_frame_base_surface-wl_surface_commit.patch b/meta-agl-flutter/recipes-graphics/toyota/files/0001-Disable-on_frame_base_surface-wl_surface_commit.patch
new file mode 100644
index 00000000..a37233b5
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/files/0001-Disable-on_frame_base_surface-wl_surface_commit.patch
@@ -0,0 +1,26 @@
+From fda28bbd6718bf113061292d8cec15084060c923 Mon Sep 17 00:00:00 2001
+From: Joel Winarske <joel.winarske@gmail.com>
+Date: Wed, 19 Jul 2023 15:21:46 -0700
+Subject: [PATCH] Disable on_frame_base_surface wl_surface_commit
+
+Signed-off-by: Joel Winarske <joel.winarske@gmail.com>
+---
+ shell/wayland/window.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/shell/wayland/window.cc b/shell/wayland/window.cc
+index c74b438..f244f08 100644
+--- a/shell/wayland/window.cc
++++ b/shell/wayland/window.cc
+@@ -257,7 +257,7 @@ void WaylandWindow::on_frame_base_surface(void* data,
+ window->m_fps_counter++;
+ window->m_fps_counter++;
+
+- wl_surface_commit(window->m_base_surface);
++ //wl_surface_commit(window->m_base_surface);
+ }
+
+ uint32_t WaylandWindow::GetFpsCounter() {
+--
+2.41.0
+
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend
new file mode 100644
index 00000000..dbc82bc3
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agl-flutter', 'flutter-auto_aglflutter.inc', '', d)}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
new file mode 100644
index 00000000..7ba85a34
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI:append:use-nxp-bsp = " file://0001-Disable-on_frame_base_surface-wl_surface_commit.patch"