summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2024-02-13 14:08:12 -0500
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-03-20 21:18:38 +0000
commitde386f3813a4abae810fc9e87bdeb6b99541a2fa (patch)
tree57c9f8a7dc5089e3bb0172c23490d14576e54b63
parent474798c27015b5138d17ab725e3675742c120b3b (diff)
Add Yocto Project scarthgap release compatibility
Switch to scarthgap in LAYERSERIES_COMPAT in layer.conf files. Bug-AGL: SPEC-4578 Change-Id: I50e341efd6a317a830352d44db1cd756d3589861 Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
-rw-r--r--meta-agl-drm-lease/conf/layer.conf2
-rw-r--r--meta-agl-flutter/conf/layer.conf2
-rw-r--r--meta-agl-ic-container/conf/layer.conf2
-rw-r--r--meta-agl-jailhouse/conf/layer.conf2
-rw-r--r--meta-agl-test/conf/layer.conf2
-rw-r--r--meta-agl-wireless-monitor/conf/layer.conf2
-rw-r--r--meta-egvirt/conf/layer.conf2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf2
-rw-r--r--meta-offline-voice-agent/conf/layer.conf2
-rw-r--r--meta-uhmi/meta-rvgpu/conf/layer.conf2
10 files changed, 10 insertions, 10 deletions
diff --git a/meta-agl-drm-lease/conf/layer.conf b/meta-agl-drm-lease/conf/layer.conf
index 26d93143..84f3165d 100644
--- a/meta-agl-drm-lease/conf/layer.conf
+++ b/meta-agl-drm-lease/conf/layer.conf
@@ -24,4 +24,4 @@ BBFILES_DYNAMIC += " \
LAYERVERSION_agl-drm-lease = "1"
LAYERDEPENDS_agl-drm-lease = "core"
-LAYERSERIES_COMPAT_agl-drm-lease = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_agl-drm-lease = "langdale mickledore nanbield scarthgap"
diff --git a/meta-agl-flutter/conf/layer.conf b/meta-agl-flutter/conf/layer.conf
index 722879b6..ecf34e95 100644
--- a/meta-agl-flutter/conf/layer.conf
+++ b/meta-agl-flutter/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PRIORITY_meta-agl-flutter = "61"
LAYERVERSION_meta-agl-flutter = "1"
LAYERDEPENDS_meta-agl-flutter = "core meta-flutter"
-LAYERSERIES_COMPAT_meta-agl-flutter = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_meta-agl-flutter = "langdale mickledore nanbield scarthgap"
diff --git a/meta-agl-ic-container/conf/layer.conf b/meta-agl-ic-container/conf/layer.conf
index c88f63f8..7fdc0bb5 100644
--- a/meta-agl-ic-container/conf/layer.conf
+++ b/meta-agl-ic-container/conf/layer.conf
@@ -18,5 +18,5 @@ BBFILES_DYNAMIC += " \
selinux:${LAYERDIR}/dynamic-layers/meta-selinux/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_aglcontainermc = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_aglcontainermc = "langdale mickledore nanbield scarthgap"
LAYERDEPENDS_aglcontainermc = "aglcore qt5-layer openembedded-layer virtualization-layer agl-drm-lease meta-pipewire"
diff --git a/meta-agl-jailhouse/conf/layer.conf b/meta-agl-jailhouse/conf/layer.conf
index e48b8155..04b59ac4 100644
--- a/meta-agl-jailhouse/conf/layer.conf
+++ b/meta-agl-jailhouse/conf/layer.conf
@@ -11,7 +11,7 @@ BBFILE_PRIORITY_agl-jailhouse = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-jailhouse = "1"
-LAYERSERIES_COMPAT_agl-jailhouse = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_agl-jailhouse = "langdale mickledore nanbield scarthgap"
# This is only needed for Raspberry Pi
# TODO: can this be expressed dynamically?
diff --git a/meta-agl-test/conf/layer.conf b/meta-agl-test/conf/layer.conf
index 9e2b59c2..4d51bbda 100644
--- a/meta-agl-test/conf/layer.conf
+++ b/meta-agl-test/conf/layer.conf
@@ -11,4 +11,4 @@ BBFILE_PATTERN_agl-test = "^${LAYERDIR}/"
# cause compatibility issues with other layers
LAYERVERSION_agl-test = "1"
-LAYERSERIES_COMPAT_agl-test = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_agl-test = "langdale mickledore nanbield scarthgap"
diff --git a/meta-agl-wireless-monitor/conf/layer.conf b/meta-agl-wireless-monitor/conf/layer.conf
index 0c31d9a7..7f036d7c 100644
--- a/meta-agl-wireless-monitor/conf/layer.conf
+++ b/meta-agl-wireless-monitor/conf/layer.conf
@@ -12,4 +12,4 @@ BBFILE_PRIORITY_agl-drm-lease = "100"
# cause compatibility issues with other layers
LAYERVERSION_agl-wireless-monitor = "1"
-LAYERSERIES_COMPAT_agl-wireless-monitor = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_agl-wireless-monitor = "langdale mickledore nanbield scarthgap"
diff --git a/meta-egvirt/conf/layer.conf b/meta-egvirt/conf/layer.conf
index 100a2df9..e5803647 100644
--- a/meta-egvirt/conf/layer.conf
+++ b/meta-egvirt/conf/layer.conf
@@ -11,6 +11,6 @@ BBFILE_PRIORITY_egvirt = "61"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_egvirt = "1"
-LAYERSERIES_COMPAT_egvirt = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_egvirt = "langdale mickledore nanbield scarthgap"
LAYERDEPENDS_egvirt = "core clang-layer filesystems-layer"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
index 5a203f9e..d647dee6 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
+++ b/meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
@@ -12,5 +12,5 @@ BBFILE_PRIORITY_agl-basesystem = "60"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_agl-basesystem = "1"
-LAYERSERIES_COMPAT_agl-basesystem = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_agl-basesystem = "langdale mickledore nanbield scarthgap"
LAYERDEPENDS_agl-basesystem = "core"
diff --git a/meta-offline-voice-agent/conf/layer.conf b/meta-offline-voice-agent/conf/layer.conf
index 11fd2855..55e599f9 100644
--- a/meta-offline-voice-agent/conf/layer.conf
+++ b/meta-offline-voice-agent/conf/layer.conf
@@ -10,7 +10,7 @@ BBFILE_PATTERN_meta-offline-voice-agent = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-offline-voice-agent = "65"
LAYERDEPENDS_meta-offline-voice-agent = "core"
-LAYERSERIES_COMPAT_meta-offline-voice-agent = "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_meta-offline-voice-agent = "langdale mickledore nanbield scarthgap"
BBFILES_DYNAMIC += " \
agldemo:${LAYERDIR}/dynamic-layers/meta-agl-demo/*/*/*.bb \
diff --git a/meta-uhmi/meta-rvgpu/conf/layer.conf b/meta-uhmi/meta-rvgpu/conf/layer.conf
index c8dc89e9..7891167d 100644
--- a/meta-uhmi/meta-rvgpu/conf/layer.conf
+++ b/meta-uhmi/meta-rvgpu/conf/layer.conf
@@ -14,4 +14,4 @@ BBFILES_DYNAMIC += " \
raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bbappend \
"
-LAYERSERIES_COMPAT_meta-rvgpu= "langdale mickledore nanbield"
+LAYERSERIES_COMPAT_meta-rvgpu= "langdale mickledore nanbield scarthgap"