summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryanxk <yanxk.fnst@fujitsu.com>2022-09-11 14:08:00 +0800
committerXinkuan Yan <yanxk.fnst@fujitsu.com>2022-12-09 06:12:09 +0000
commit349797c2b1fb1c9180f21573dded08e2bf09c131 (patch)
treeb9157345597d5c8864a66d647cdd50ec8a9f0b25
parent767f756814ce15379abe6f60c21e1a4ecc3db1c2 (diff)
meta-agl-test: provide pytest-order for framework
pytest-order is now ready for the framework to use. it is now migrated into agl-test-framework. Bug-AGL: SPEC-4345 Signed-off-by: yanxk <yanxk.fnst@fujitsu.com> Change-Id: If5dbd30be3227086200469b394f78cc5df745317
-rw-r--r--meta-agl-test/recipes-external/python3-pytest-order/python3-pytest-order_1.0.1.bb17
-rw-r--r--meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb1
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-test/recipes-external/python3-pytest-order/python3-pytest-order_1.0.1.bb b/meta-agl-test/recipes-external/python3-pytest-order/python3-pytest-order_1.0.1.bb
new file mode 100644
index 00000000..3524d4d0
--- /dev/null
+++ b/meta-agl-test/recipes-external/python3-pytest-order/python3-pytest-order_1.0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "pytest plugin for test sequence."
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=759a21ef176b699c267d76f658c38340"
+
+SRC_URI[sha256sum] = "5dd6b929fbd7eaa6d0ee07586f65c623babb0afe72b4843c5f15055d6b3b1b1f"
+
+PYPI_PACKAGE = "pytest-order"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-pytest \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb b/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb
index e253e2a5..3360e014 100644
--- a/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb
+++ b/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb
@@ -38,4 +38,5 @@ do_install:append() {
RDEPENDS:${PN} += " \
python3-pytest \
python3-jinja2 \
+ python3-pytest-order \
"