aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-15 14:03:53 -0400
committerScott Murray <scott.murray@konsulko.com>2019-10-15 14:03:53 -0400
commit479697d20ac25fa6c457e7ec2af78a0f145c8a49 (patch)
tree7b21ffe408092554f8a69d8af8b9b204a4775e23
parentb3e788595dd3059983bcb508c93931eeb2acb66a (diff)
alexa-voiceagent-service: build in debug mode
Tweak the CMake flags to build alexa-voiceagent-service in debug mode (hopefully temporarily) to avoid the known crash tracked in SPEC-2873. This also matches the build instructions given in the README.md in alexa-auto-sdk upstream as of version 2.0. Bug-AGL: SPEC-2873 Change-Id: I2bc7b14412089660ea253a50bcbe4079e2670be0 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
index 296cf2d2..92b54e22 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
@@ -33,6 +33,10 @@ S = "${WORKDIR}/git/platforms/agl/alexa-voiceagent-service"
inherit cmake aglwgt
EXTRA_OECMAKE += "-DAAC_HOME=${RECIPE_SYSROOT}/${AAC_PREFIX}"
+# Build in debug mode (hopefully temporarily) to avoid crash tracked
+# in SPEC-2873. This also matches the build instructions given in the
+# README.md in alexa-auto-sdk upstream as of version 2.0.
+EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=Debug"
# NOTE: curl and opus are from the base SDK libraries, sqlite3 from the
# core module