aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-12-18 18:50:59 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-18 20:52:03 +0000
commitfa05107c7e85a8d35395f26c126a520175bc2582 (patch)
tree00cb014c0f06d4ca2a5af445a1adfa1043745cbc
parent342505cd7d3356df22b485464fe089f39f619264 (diff)
Also let the user specify the wakeword engine status
To enable the wakeword engine you need to have the plugin available and set ALEXA_WAKEWORD in your conf/local.conf to true. Change-Id: If7266c8ac9f773ee29dffc7494d55f323e76b63e Bug-AGL: SPEC-3054 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
index f3a6af9d..7e5992bb 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
@@ -10,6 +10,8 @@ SRC_URI = "file://AlexaAutoCoreEngineConfig.json.in"
inherit allarch
+ALEXA_WAKEWORD ??= "false"
+
do_compile () {
if test x"${ALEXA_CLIENTID}" == x"" ; then
@@ -28,7 +30,7 @@ do_compile () {
do_install () {
#replace
- sed -e "s/@@ALEXA_CLIENTID@@/${ALEXA_CLIENTID}/" -e "s/@@ALEXA_SERIALNUMBER@@/${ALEXA_SERIALNUMBER}/" -e "s/@@ALEXA_PRODUCTID@@/${ALEXA_PRODUCTID}/" ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
+ sed -e "s/@@ALEXA_CLIENTID@@/${ALEXA_CLIENTID}/" -e "s/@@ALEXA_SERIALNUMBER@@/${ALEXA_SERIALNUMBER}/" -e "s/@@ALEXA_PRODUCTID@@/${ALEXA_PRODUCTID}/" -e "s/@@WAKEWORD@@/${ALEXA_WAKEWORD}/" ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
# install
install -D -m 644 ${WORKDIR}/AlexaAutoCoreEngineConfig.json ${D}${sysconfdir}/xdg/AGL/AlexaAutoCoreEngineConfig.json