summaryrefslogtreecommitdiffstats
path: root/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-05-21 14:04:04 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-06-01 05:56:00 +0900
commit0b77534d91ce0cfaf5fe1dbfbc64912d64e2b29b (patch)
tree91bd4c893915e203ce1fa3403cf74c74aa1c2314 /meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
parent0f2a0480c17a2bab7692a7ce56c34ccb5201854a (diff)
Last psplash patch has some HACK implementation for drl lease support. It cause complex change to psplash service file. This patch fix this issue reusing sandbox/ishii.hiroyuki/psplash-drm, that is worked by ishii hiroyuki. Bug-AGL: SPEC-4804 Change-Id: Ie98b8fb73534c3d1114580ea1d6ca238e62e6c7a Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend')
-rw-r--r--meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
index 56650669..53adec9c 100644
--- a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
@@ -25,19 +25,19 @@ SRC_URI += " \
SRC_URI += " \
file://0016-Imprement-drm-lease-support.patch \
file://0017-drm-lease-Fix-incorrect-drawing-with-portrait-orient.patch \
+ file://psplash-drmlease.conf \
"
# Licesnse checksum was changed by above patches
LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=db1ed16abf4be6de3d79201093ac4f07"
-PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
-PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm', '--drm', '', d)}"
+PACKAGECONFIG:append = " drm drm-lease"
+PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
PACKAGECONFIG[drm-lease] = "--enable-drm-lease,,drm-lease-manager"
-PSPLASH_DRM_LEASE_ARGS ??= "--drm-lease lease0"
-PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', '${PSPLASH_DRM_LEASE_ARGS}', '', d)}"
-RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', 'drm-lease-manager', '', d)}"
do_install:append () {
- sed -i -e "s!^\(ExecStart=/usr/bin/psplash.*\)!\1 ${PSPLASH_ARGS}!" ${D}${systemd_system_unitdir}/psplash-start.service
+ # Install override
+ install -d ${D}${systemd_system_unitdir}/psplash-start.service.d
+ install -m 0644 ${WORKDIR}/psplash-drmlease.conf ${D}${systemd_system_unitdir}/psplash-start.service.d/
}