aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-04-23 20:25:45 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2023-05-09 08:13:10 +0900
commitb3e49987c5706612ee342c685dea799be596df6a (patch)
tree7c4e724755638a387fa7bf555e050f59be81fbbe /meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
parenta070ad4db8e4a35fc34b0610b56dcfc1e2caaad3 (diff)
Enable drm-lease support at psplash
The upstream version of psplash is supporting fb based splash screen. On the other hand, drm lease infrastructure is not support fb. This patch enable drm-lease support at psplash. This work contributed by Hiroyuki Ishii at CES2023 demo development. Bug-AGL: SPEC-4766 Change-Id: I50b382c7f8ca4b46a8fb06fd649d0cfa49800c6d Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend')
-rw-r--r--meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
new file mode 100644
index 00000000..56650669
--- /dev/null
+++ b/meta-agl-drm-lease/recipes-core/psplash/psplash_git.bbappend
@@ -0,0 +1,43 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+# drm-backend backport from:
+# https://patchwork.yoctoproject.org/project/yocto/cover/20220425075954.10427-1-vasyl.vavrychuk@opensynergy.com/
+SRC_URI += " \
+ file://0001-Fix-duplicated-definition-of-bool.patch \
+ file://0002-Trim-trailing-spaces.patch \
+ file://0003-Fix-unused-result-warnings.patch \
+ file://0004-Remove-unused-save_termios.patch \
+ file://0005-Remove-psplash-fb.h-from-psplash.h.patch \
+ file://0006-Extract-plot-pixel-from-psplash-fb.patch \
+ file://0007-Extract-draw-rect-image-from-psplash-fb.patch \
+ file://0008-Extract-draw-font-from-psplash-fb.patch \
+ file://0009-psplash.c-Make-psplash_draw_-msg-progress-independen.patch \
+ file://0010-Rework-flip-as-function-pointer.patch \
+ file://0011-Import-drm-howto-modeset.c-as-psplash-drm.c.patch \
+ file://0012-Implement-drm-backend.patch \
+ file://0013-Reverse-modeset_list.patch \
+ file://0014-psplash-drm.c-Allocate-resources-only-for-the-first-.patch \
+ file://0015-psplash-drm.c-Implement-double-buffering.patch \
+ "
+
+# drm-lease support from:
+# https://github.com/agl-ic-eg/meta-agl-demo/tree/main/recipes-core/psplash
+SRC_URI += " \
+ file://0016-Imprement-drm-lease-support.patch \
+ file://0017-drm-lease-Fix-incorrect-drawing-with-portrait-orient.patch \
+ "
+
+# Licesnse checksum was changed by above patches
+LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=db1ed16abf4be6de3d79201093ac4f07"
+
+PACKAGECONFIG[drm] = "--enable-drm,,libdrm"
+PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm', '--drm', '', d)}"
+
+PACKAGECONFIG[drm-lease] = "--enable-drm-lease,,drm-lease-manager"
+PSPLASH_DRM_LEASE_ARGS ??= "--drm-lease lease0"
+PSPLASH_ARGS += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', '${PSPLASH_DRM_LEASE_ARGS}', '', d)}"
+RDEPENDS:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'drm-lease', 'drm-lease-manager', '', d)}"
+
+do_install:append () {
+ sed -i -e "s!^\(ExecStart=/usr/bin/psplash.*\)!\1 ${PSPLASH_ARGS}!" ${D}${systemd_system_unitdir}/psplash-start.service
+}