summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-06 17:06:54 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-12 11:10:26 +0000
commit83bbf82c41de1d532a920fa42326c17f40ea172f (patch)
treefaadb04910185130d74f367cbb9407c77f7993c8 /meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
parent0ccbb175eb5efdb59d0231198b295a21e3c466db (diff)
meta-agl-flutter: update for meta-agl-core changes
Changes: - Pull in image .bb files instead of .inc files. - Use agl-image-compositor as the base image for agl-image-flutter. instead of the appending done to agl-image-weston and its packagegroup previously. - Rework flutter-gallery systemd unit to work again, and update our bbappend to install it as disabled as an option for starting up flutter-gallery in agl-image-flutter. It seems useful to keep it present to serve as an example of starting Flutter apps via systemd and using the agl-flutter-env package. - Some minor documentation updates in README.md. - Replace some :append usage with += to avoid creating problems for downstream users. Bug-AGL: SPEC-4813 Change-Id: I8a61d6365ce69ac50b88abc7bc451486b3e1b339 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service')
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
index 3d4ecbf1..80e31dda 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-gallery/flutter-gallery.service
@@ -3,8 +3,11 @@ Requires=agl-compositor.service
After=agl-compositor.service
[Service]
-ExecStart=/usr/bin/flutter-auto --j=/usr/share/flutter/default.json --b=/usr/share/flutter/gallery --f
-Restart=on-failure
+User=agl-driver
+EnvironmentFile=/etc/default/flutter
+EnvironmentFile=-/etc/default/flutter-gallery
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
+ExecStart=/usr/bin/flutter-auto --b=/usr/share/flutter/gallery/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --f --window-type=BG
[Install]
-WantedBy=agl-session.target
+WantedBy=graphical.target