summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-graphics/flutter-apps
diff options
context:
space:
mode:
authorJoel Winarske <joel.winarske@gmail.com>2022-07-15 08:17:15 -0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-07-19 12:48:47 +0000
commit00cb1f6650477dcf5904388e81a551cd4a2e2f22 (patch)
tree170a3fde63a8dd79be96a1ed3c7013f21c36c731 /meta-agl-flutter/recipes-graphics/flutter-apps
parent76599360b8dbe1307e6d38f39517668aa8239081 (diff)
meta-agl-flutter:Application updates
-upstream is now pinning ivi-homescreen -fix breaking change. Change --a to --b -adds test apps to images: secure storage, EGL texture, and video_player -adds Igalia homescreen to images -add Pumped Fuel ped recipe to images v2 (jsmoeller): fixup missing require in recipes v3 (jsmoeller): rework duplication in recipes and use BBCLASSEXTEND v4 (jsmoeller): add dependencies to application framework and pipewire v5 (jsmoeller): update agl-image-flutter to use new naming Signed-off-by: Joel Winarske <joel.winarske@gmail.com> Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I924335eb2ceb9ad91944630b43b72a6fe296b98d
Diffstat (limited to 'meta-agl-flutter/recipes-graphics/flutter-apps')
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-igalia-homescreen_git.bb (renamed from meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb)4
-rw-r--r--meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb34
2 files changed, 37 insertions, 1 deletions
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-igalia-homescreen_git.bb
index c5c8b2ae..9047d603 100644
--- a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-homescreen_git.bb
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-igalia-homescreen_git.bb
@@ -1,5 +1,5 @@
SUMMARY = "Igalia Flutter Homescreen"
-DESCRIPTION = "Flutter Gallery Application"
+DESCRIPTION = "A prototype home screen for automotive grade Linux."
AUTHOR = "Igalia"
HOMEPAGE = "https://github.com/felipeerias/flutter_homescreen"
BUGTRACKER = "https://github.com/felipeerias/flutter_homescreen/issues"
@@ -20,3 +20,5 @@ FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
FLUTTER_BUILD_ARGS = "bundle -v"
inherit flutter-app
+
+BBCLASSEXTEND = "flutterrelease flutterprofile flutterdebug" \ No newline at end of file
diff --git a/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb
new file mode 100644
index 00000000..541bc8ec
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/flutter-apps/flutter-app-pumped-fuel-ped_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Pumped End Device"
+DESCRIPTION = "Pumped is a combination of 3 core projects to connect \
+ vehicle drivers with retail merchants, initially starting \
+ with fuel stations. Our objective is to offer the best fuel \
+ prices, closest stations, friendliest service, cleanest restrooms, \
+ tastiest coffee and so much more, direct to vehicle drivers."
+AUTHOR = "Pumped Fuel"
+HOMEPAGE = "https://github.com/bernardpumped/ped"
+BUGTRACKER = "https://github.com/bernardpumped/ped/issues"
+SECTION = "graphics"
+
+RDEPENDS:${PN} += "\
+ geoclue \
+ libsecret \
+ xdg-user-dirs \
+ "
+
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e49f4652534af377a713df3d9dec60cb"
+
+SRC_URI = "git://github.com/bernardpumped/ped.git;protocol=https;branch=main"
+
+SRCREV = "7a670295d5a94508862316e045e789e0dfd01b20"
+
+S = "${WORKDIR}/git"
+
+PUBSPEC_APPNAME = "pumped_end_device"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+inherit flutter-app
+
+BBCLASSEXTEND += "flutterrelease flutterdebug flutterprofile"