summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-graphics/toyota
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-08-04 16:53:39 -0400
committerScott Murray <scott.murray@konsulko.com>2022-08-04 17:22:30 -0400
commit33cdbee53ea3ec3d2f88e05744ea9e6611c40772 (patch)
tree62000e5a204ec9fdd6442cdb31b8199e46b9535a /meta-agl-flutter/recipes-graphics/toyota
parentadbb12626100901bc815deba27733fe1a3ebc3cc (diff)
meta-agl-flutter: Simplify AGL integration
Changes: - Remove Igalia homescreen and Pumped Fuel app recipes since they duplicate what is in meta-flutter. Now that there is a AGL Flutter demo image in meta-agl, any recipes or bbappends for apps should go there except for the flutter-gallery integration for agl-image-flutter (see below). - Move flutter-gallery systemd unit changes out of flutter-auto bbappend to a new flutter-gallery bbappend to simplify using flutter-auto on its own. To facilitate interoperation with the use of flutter-gallery in the agl-ivi-demo-platform-flutter image, the systemd files are split out into a -init package that has been added to agl-image-flutter. - Added back a reworked version of the app-id command-line option patch in the flutter-auto bbappend with the option changed to --xdg-shell-app-id per upstream request. This wil be submitted upstream as time permits. The merged patches that were deleted have been removed from SRC_URI. The intent of the above is to move to meta-agl-flutter just having the minimal set of changes to integrate flutter-auto with AGL use, with the agl-image-flutter image kept as a simple smoketest / example. Bug-AGL: SPEC-4485 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I171852820be404774d7580778643c801e8fad34f
Diffstat (limited to 'meta-agl-flutter/recipes-graphics/toyota')
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch38
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/flutter-auto.service10
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-debug.json11
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-profile.json11
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-release.json10
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend (renamed from meta-agl-flutter/recipes-graphics/toyota/flutter-auto%.bbappend)0
-rw-r--r--meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc47
7 files changed, 44 insertions, 83 deletions
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch b/meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch
new file mode 100644
index 00000000..854c8dc8
--- /dev/null
+++ b/meta-agl-flutter/recipes-graphics/toyota/files/0001-Add-xdg-shell-app-id-command-line-argument.patch
@@ -0,0 +1,38 @@
+From 394f48a1e535f464879fa94196ee6d73b86894f5 Mon Sep 17 00:00:00 2001
+From: Scott Murray <scott.murray@konsulko.com>
+Date: Thu, 4 Aug 2022 14:36:08 -0400
+Subject: [PATCH] Add xdg-shell-app-id command-line argument
+
+Add a command-line argument for specifying the app id, so that basic
+applications do not need to supply a full JSON configuration just to
+do so.
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ shell/main.cc | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/shell/main.cc b/shell/main.cc
+index deb4876..ba35acc 100644
+--- a/shell/main.cc
++++ b/shell/main.cc
+@@ -161,6 +161,16 @@ int main(int argc, char** argv) {
+ FML_DLOG(INFO) << "Window Type: " << config.view.window_type;
+ RemoveArgument(config.view.vm_args, "--window-type=" + config.view.window_type);
+ }
++ if (cl.HasOption("xdg-shell-app-id")) {
++ cl.GetOptionValue("xdg-shell-app-id", &config.app_id);
++ if (config.app_id.empty()) {
++ FML_LOG(ERROR)
++ << "--xdg-shell-app-id option requires an argument (e.g. --xdg-shell-app-id=gallery)";
++ return EXIT_FAILURE;
++ }
++ FML_DLOG(INFO) << "Application ID: " << config.app_id;
++ RemoveArgument(config.view.vm_args, "--xdg-shell-app-id=" + config.app_id);
++ }
+ }
+
+ auto vm_arg_count = config.view.vm_args.size();
+--
+2.35.3
+
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/flutter-auto.service b/meta-agl-flutter/recipes-graphics/toyota/files/flutter-auto.service
deleted file mode 100644
index 71ab791d..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/files/flutter-auto.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Requires=agl-compositor.service
-After=agl-compositor.service
-
-[Service]
-ExecStart=/usr/bin/flutter-auto --j=/usr/share/flutter/default.json
-Restart=on-failure
-
-[Install]
-WantedBy=agl-session.target
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-debug.json b/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-debug.json
deleted file mode 100644
index 5a84a0bd..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-debug.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/gallery",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-profile.json b/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-profile.json
deleted file mode 100644
index 3309fde4..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-profile.json
+++ /dev/null
@@ -1,11 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/gallery",
- "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234", "--start-paused"],
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-release.json b/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-release.json
deleted file mode 100644
index 6a2a8448..00000000
--- a/meta-agl-flutter/recipes-graphics/toyota/files/gallery_on_bg-release.json
+++ /dev/null
@@ -1,10 +0,0 @@
-{
- "view" : [ {
- "window_type" : "BG",
- "bundle_path" : "/usr/share/flutter/gallery",
- "width" : 1920,
- "height": 1080,
- "fullscreen": true
- }
- ]
-}
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto%.bbappend b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend
index dbc82bc3..dbc82bc3 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto%.bbappend
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_%.bbappend
diff --git a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
index 4baaa517..0b580c2a 100644
--- a/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
+++ b/meta-agl-flutter/recipes-graphics/toyota/flutter-auto_aglflutter.inc
@@ -1,47 +1,12 @@
+FILESEXTRAPATHS:append := "${THISDIR}/files:"
+
+SRC_URI += " \
+ file://0001-Add-xdg-shell-app-id-command-line-argument.patch \
+"
+
# For now disable gstreamer to avoid needing to enable "commercial"
# licenses for the stated ffmpeg dependency.
PACKAGECONFIG:remove = "gstreamer"
# Enable verbose logging on runtimedebug image
PACKAGECONFIG:append:runtimedebug = "verbose"
-
-
-USER_SERVICE = "flutter-auto.service"
-
-FILESEXTRAPATHS:append := "${THISDIR}/files:"
-SRC_URI += "\
- file://${USER_SERVICE} \
- file://gallery_on_bg-debug.json \
- file://gallery_on_bg-profile.json \
- file://gallery_on_bg-release.json \
- file://0002-shell-configuration-Obey-json-configuration-file.patch \
- file://0003-shell-configuration-Fixes-to-general-options.patch \
- file://0004-Add-app-id-command-line-argument.patch \
- "
-
-
-cmake_do_install:append() {
-
- install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
- install -D -m0644 ${WORKDIR}/${USER_SERVICE} ${D}${systemd_user_unitdir}/${USER_SERVICE}
-
- install -D -m0644 ${WORKDIR}/gallery_on_bg-release.json ${D}${datadir}/flutter/default.json
-}
-
-cmake_do_install:append:runtimedebug() {
-
- # the dev host controls starting/stopping the flutter-auto process when runtime=debug
- install -D -m0644 ${WORKDIR}/gallery_on_bg-debug.json ${D}${datadir}/flutter/default.json
-}
-
-cmake_do_install:append:runtimeprofile() {
-
- # the dev host controls starting/stopping the flutter-auto process when runtime=profile
- install -D -m0644 ${WORKDIR}/gallery_on_bg-profile.json ${D}${datadir}/flutter/default.json
-}
-
-
-FILES:${PN} += "\
- ${systemd_user_unitdir} \
- ${datadir} \
- "