summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:43:04 +0200
commit13169c3265ba75d783eb3723504298a08e768110 (patch)
tree9f30b921d3491ad9bc8a55d58fd3bf6f3db8800e /meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
parentce87122d195d3a1fea454cfa4acd91e22ccea264 (diff)
Rename Instrument Cluster Container layer
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend')
-rw-r--r--meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend b/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
new file mode 100644
index 00000000..75ab98c0
--- /dev/null
+++ b/meta-agl-ic-container/recipes-container/lxc/lxc_%.bbappend
@@ -0,0 +1,25 @@
+PACKAGECONFIG:remove = "templates"
+
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI += " \
+ file://lxc.service \
+ file://lxc-net.service \
+ "
+
+do_install:append () {
+ for service in lxc.service lxc-net.service; do
+ install -D -m 0644 ${WORKDIR}/$service ${D}${systemd_system_unitdir}/$service
+ sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_system_unitdir}/$service
+ done
+}
+
+# NOTE:
+# This needs to be replaced with a rework of the upstream packaging
+# to do a proper split of core from the template support.
+RDEPENDS:${PN} = ""
+
+
+