summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-demo/ilm-manager
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:45:17 +0200
commit68fa652a418a5dfcee12386fd58939bfd626144d (patch)
tree35db36536266979f085683985f5f0e5249df8e1f /meta-agl-ic-container/recipes-demo/ilm-manager
parent17087e4083b2b6b070cec55c38288644689fa55c (diff)
Rename Instrument Cluster Container layerneedlefish_14.0.0needlefish/14.0.014.0.0
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-ic-container/recipes-demo/ilm-manager')
-rw-r--r--meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/agl.json70
-rw-r--r--meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service12
-rw-r--r--meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager_git.bb31
3 files changed, 113 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/agl.json b/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/agl.json
new file mode 100644
index 00000000..80028c50
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/agl.json
@@ -0,0 +1,70 @@
+{
+ "screen": [
+ {
+ "name": "ivi-screen",
+ "dispname": "HDMI-A-1"
+ }
+ ],
+ "layer": [
+ {
+ "name": "ivi-layer",
+ "id": 2000,
+ "width": 1920,
+ "height": 1080,
+ "x": 0,
+ "y": 0,
+ "z": 10,
+ "attach": "ivi-screen"
+ }
+ ],
+ "surface": [
+ {
+ "name": "momiscreen",
+ "id": 2000,
+ "x": 0,
+ "y": 988,
+ "z": 10,
+ "attach": "ivi-layer"
+ },
+ {
+ "name": "mominavi",
+ "id": 2010,
+ "x": 0,
+ "y": 0,
+ "z": 100,
+ "attach": "ivi-layer"
+ },
+ {
+ "name": "momiplay",
+ "id": 2011,
+ "x": 0,
+ "y": 0,
+ "z": 110,
+ "attach": "ivi-layer"
+ },
+ {
+ "name": "momiradio",
+ "id": 2012,
+ "x": 0,
+ "y": 0,
+ "z": 120,
+ "attach": "ivi-layer"
+ },
+ {
+ "name": "momisetting",
+ "id": 2013,
+ "x": 0,
+ "y": 0,
+ "z": 130,
+ "attach": "ivi-layer"
+ },
+ {
+ "name": "xdg-test",
+ "id": 9801,
+ "x": 0,
+ "y": 0,
+ "z": 300,
+ "attach": "ivi-layer"
+ }
+ ]
+}
diff --git a/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service b/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service
new file mode 100644
index 00000000..b91b65f1
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Tiny Window Manager
+After=weston.service
+Wants=weston.service
+
+[Service]
+Type=simple
+EnvironmentFile=/etc/default/weston
+ExecStart=/usr/bin/ilmmanager
+
+[Install]
+WantedBy=weston.service
diff --git a/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager_git.bb b/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager_git.bb
new file mode 100644
index 00000000..2f976b39
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/ilm-manager/ilm-manager_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Tiny window manager for wayland-ivi-extension"
+DESCRIPTION = "Tiny window manager for wayland-ivi-extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+DEPENDS = "jsoncpp wayland-ivi-extension"
+
+PV = "0.1.0+rev${SRCPV}"
+
+SRCREV = "e3a33d47195e4656f7117753d27a0f2d6b21aab9"
+SRC_URI = " \
+ git://github.com/AGLExport/ilm-manager.git;branch=master;protocol=https \
+ file://agl.json \
+ file://ilm-manager.service \
+ "
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig systemd
+
+do_install:append() {
+ #install scripts
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/agl.json ${D}${sysconfdir}
+
+ install -d ${D}/${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/ilm-manager.service ${D}${systemd_system_unitdir}
+}
+
+FILES:${PN} += " ${systemd_system_unitdir} ${sysconfdir} "
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "ilm-manager.service"