summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:45:17 +0200
commit68fa652a418a5dfcee12386fd58939bfd626144d (patch)
tree35db36536266979f085683985f5f0e5249df8e1f /meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
parent17087e4083b2b6b070cec55c38288644689fa55c (diff)
Rename Instrument Cluster Container layerneedlefish_14.0.0needlefish/14.0.014.0.0
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb')
-rw-r--r--meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb b/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
new file mode 100644
index 00000000..f37a5365
--- /dev/null
+++ b/meta-agl-ic-container/recipes-demo/momiscreen/momiscreen_git.bb
@@ -0,0 +1,43 @@
+SUMMARY = "Momiyama home screen example"
+DESCRIPTION = "The momiscreen is a home screen example. \
+ The momiscreen is not require agl-appfw."
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS = " \
+ qtbase \
+ qtquickcontrols2 \
+ qtgraphicaleffects \
+ qtsvg \
+ "
+
+PV = "0.2.0"
+
+SRC_URI = "git://github.com/AGLExport/momiscreen.git;protocol=https;branch=main \
+ file://momiscreen.service \
+ file://momiscreen \
+ "
+SRCREV = "bc3ef09ffad15b97941f28b165dc2019f5950105"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 systemd
+
+QT_INSTALL_PREFIX = "/usr"
+
+do_install:append() {
+ install -d ${D}/${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/momiscreen.service ${D}/${systemd_unitdir}/system
+
+ install -m 0755 -d ${D}${sysconfdir}/default/
+ install -m 0755 ${WORKDIR}/momiscreen ${D}${sysconfdir}/default/
+}
+
+FILES:${PN} += " \
+ ${systemd_unitdir} \
+ ${sysconfdir}/*/* \
+ "
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "momiscreen.service"
+
+RDEPENDS:${PN} = "qtsvg "