summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-11-26 00:55:00 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-29 17:17:03 +0000
commit81f834e59c4896fe771a18de4b4a445d0aba1fdb (patch)
tree9e829951c9eda3b4932c766d828a25c569508a27 /meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb
parent195e125f238d4a08b4f4306c5815fdb2740dc984 (diff)
Revert "Remove weston with wayland-ivi-extention"
This reverts commit 24f2da7bfd7fa66e8a3b8ed7e5d8c09ef6956c68. Bug-AGL: SPEC-5308 Change-Id: Ibf15daed630f08ad07bf6f91aaef016927eee0ac Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>
Diffstat (limited to 'meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb')
-rw-r--r--meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb
new file mode 100644
index 00000000..56090f5d
--- /dev/null
+++ b/meta-agl-ic-container/recipes-graphics/wayland/wayland-ivi-extension_git.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "https://github.com/COVESA/wayland-ivi-extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
+
+DEPENDS = "weston virtual/libgles2 pixman wayland-native"
+
+PV = "2.3.2+git${SRCPV}"
+
+SRC_URI = " \
+ git://github.com/COVESA/${BPN}.git;protocol=https;branch=master \
+ file://0001-Update-libweston-to-version-13.patch \
+"
+SRCREV = "60d616ad3abd925956207b9b6ff981afa004e792"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
+EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"
+
+FILES:${PN} += "${datadir}/wayland-protocols/stable/ivi-application/ivi-application.xml"
+FILES:${PN} += "${libdir}/weston/*"
+FILES:${PN}-dbg += "${libdir}/weston/.debug/*"
+
+# Need these temporarily to prevent a non-fatal do_package_qa issue
+INSANE_SKIP:${PN} += "dev-deps"
+INSANE_SKIP:${PN}-dev += "dev-elf dev-so"