summaryrefslogtreecommitdiffstats
path: root/meta-agl-ic-container/recipes-kernel/linux
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:43:04 +0200
commit13169c3265ba75d783eb3723504298a08e768110 (patch)
tree9f30b921d3491ad9bc8a55d58fd3bf6f3db8800e /meta-agl-ic-container/recipes-kernel/linux
parentce87122d195d3a1fea454cfa4acd91e22ccea264 (diff)
Rename Instrument Cluster Container layer
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-ic-container/recipes-kernel/linux')
-rw-r--r--meta-agl-ic-container/recipes-kernel/linux/linux-%.bbappend1
-rw-r--r--meta-agl-ic-container/recipes-kernel/linux/linux/lxc-net.cfg5
-rw-r--r--meta-agl-ic-container/recipes-kernel/linux/linux/lxc.cfg26
-rw-r--r--meta-agl-ic-container/recipes-kernel/linux/linux_lxc.inc10
4 files changed, 42 insertions, 0 deletions
diff --git a/meta-agl-ic-container/recipes-kernel/linux/linux-%.bbappend b/meta-agl-ic-container/recipes-kernel/linux/linux-%.bbappend
new file mode 100644
index 00000000..d50b5d66
--- /dev/null
+++ b/meta-agl-ic-container/recipes-kernel/linux/linux-%.bbappend
@@ -0,0 +1 @@
+include ${@'linux_lxc.inc' if bb.data.inherits_class('kernel', d) else ''}
diff --git a/meta-agl-ic-container/recipes-kernel/linux/linux/lxc-net.cfg b/meta-agl-ic-container/recipes-kernel/linux/linux/lxc-net.cfg
new file mode 100644
index 00000000..e9bd7b80
--- /dev/null
+++ b/meta-agl-ic-container/recipes-kernel/linux/linux/lxc-net.cfg
@@ -0,0 +1,5 @@
+CONFIG_NETFILTER_XT_MATCH_ADDRTYPE=m
+CONFIG_NETFILTER_XT_MATCH_MULTIPORT=m
+CONFIG_IP_NF_FILTER=m
+CONFIG_NF_NAT=m
+CONFIG_NF_CONNTRACK=y
diff --git a/meta-agl-ic-container/recipes-kernel/linux/linux/lxc.cfg b/meta-agl-ic-container/recipes-kernel/linux/linux/lxc.cfg
new file mode 100644
index 00000000..fb87ea19
--- /dev/null
+++ b/meta-agl-ic-container/recipes-kernel/linux/linux/lxc.cfg
@@ -0,0 +1,26 @@
+CONFIG_CGROUP_DEVICE=y
+CONFIG_CPUSETS=y
+CONFIG_PROC_PID_CPUSET=y
+CONFIG_MEMCG=y
+CONFIG_CGROUP_SCHED=y
+CONFIG_FAIR_GROUP_SCHED=y
+CONFIG_RT_GROUP_SCHED=y
+CONFIG_CHECKPOINT_RESTORE=y
+CONFIG_NAMESPACES=y
+CONFIG_UTS_NS=y
+CONFIG_IPC_NS=y
+CONFIG_USER_NS=y
+CONFIG_PID_NS=y
+CONFIG_NET_NS=y
+
+CONFIG_NET_CLS_CGROUP=m
+CONFIG_BLK_CGROUP=y
+CONFIG_CGROUP_NET_PRIO=y
+
+# Virtual drivers
+CONFIG_HVC_DRIVER=y
+
+# Support for virtual ethernet and LXC
+CONFIG_VETH=y
+CONFIG_MACVLAN=y
+CONFIG_VXLAN=m
diff --git a/meta-agl-ic-container/recipes-kernel/linux/linux_lxc.inc b/meta-agl-ic-container/recipes-kernel/linux/linux_lxc.inc
new file mode 100644
index 00000000..87e1edc5
--- /dev/null
+++ b/meta-agl-ic-container/recipes-kernel/linux/linux_lxc.inc
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux:"
+
+# Disable all other AGL provided kernel configuration (barring
+# base BSP provided configuration), and just enable a locally
+# provided fragment with minimal LXC required configuration.
+AGL_KCONFIG_FRAGMENTS += "lxc.cfg "
+AGL_KCONFIG_FRAGMENTS += "lxc-net.cfg "
+
+
+