summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-27 22:28:29 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-27 22:31:24 +0200
commitc1c38eaa75539f4eff86ad144427fdbb155ab251 (patch)
tree05fce07e68dde523fc363c2235f7a3e1146a423e /meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp
parenta22aad5cfd2c4bf5d5c0fdf81c830e78c7456848 (diff)
meta-agl-devel: remove meta-agl-jailhouse
Unused and unmaintained. Restore if you intent to maintain it. Bug-AGL: SPEC-5151 Change-Id: I9c57689b06474b74051db8d6a436309cab65c1f8 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp')
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend31
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend21
2 files changed, 0 insertions, 52 deletions
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
deleted file mode 100644
index ce7b0227..00000000
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ /dev/null
@@ -1,31 +0,0 @@
-
-do_deploy:append:raspberrypi4() {
- # if ARMSTUB is set, it should be set in config.txt by earlier recipes, so replace it
- if [ -n "${ARMSTUB}" ]; then
- sed -i 's/^armstub=.*/armstub=bl31.bin/' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-
- if ! grep '^enable_gic' config.txt; then
- sed -i 's/^enable_gic=.*/enable_gic=1/' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- else
- echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- fi
-
- # otherwise, set it
- else
- echo "# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "armstub=bl31.bin" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- fi
-
- sed -i -e "s#dtoverlay=mcp2515.*##g" ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "# Enable CAN (Waveshare RS485 CAN HAT)" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "dtoverlay=mcp2515-can0,oscillator=8000000,interrupt=25,spimaxfrequency=1000000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-
- # memory reserved for Jailhouse
- echo "dtoverlay=jailhouse-memory" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "dtoverlay=jailhouse-memory,start=0xe0000000,size=0x200000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
-
-
-}
-
-
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
deleted file mode 100644
index e84d2409..00000000
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ /dev/null
@@ -1,21 +0,0 @@
-COMPATIBLE_MACHINE = "raspberrypi4"
-TFA_BUILD_TARGET = "bl31"
-TFA_PLATFORM = "rpi4"
-
-# Skip installing the binary into /lib/firmware. We only need it on the boot
-# partition that is generated from the files in DEPLOYDIR
-do_install[noexec] = "1"
-
-FILES:${PN} = ""
-
-do_deploy() {
- if ${@"true" if d.getVar('TFA_DEBUG') == '1' else "false"}; then
- BUILD_PLAT=${B}/${BUILD_DIR}/debug/
- else
- BUILD_PLAT=${B}/${BUILD_DIR}/release/
- fi
-
- install -d ${DEPLOYDIR}/bcm2835-bootfiles
- cp ${BUILD_PLAT}/bl31.bin ${DEPLOYDIR}/bcm2835-bootfiles/bl31.bin
-}
-