summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
diff options
context:
space:
mode:
authorAnmol <anmol.karan123@gmail.com>2021-07-27 22:15:00 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2021-08-09 22:33:49 +0200
commit4d9d7b0fc155fd9c30784ec2b1896796086ba575 (patch)
tree3eaf1fa519b2923b9a3774fb90ad15e0fc61c5cb /meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
parentaac67cb520cd945f960189d12ea9bbe1815891de (diff)
meta-agl-jailhouse: Update the Jailhouse configuration files
The current state and Information about the patch: - Updated Jailhouse root-cell(qemu-agl.c), apic-demo(agl-apic-demo.c), ivshmem-demo(agl-ivshmem-demo.c). - Jailhouse non-root cell(agl-linux-x86-demo.c) is also working, but need some more tweak for UART redirection. - Linux Kernel updated to the latest `queues/jailhouse` kernel branch. - Updated the `recipes-kernel` structure to a more custom one. - Updated conf/local.conf according to new `recipes-kernel` structure. - Removed the Linux Kernel patches from the `recipes-kernel` as updated kernel already contain those patches. This patch is the initial block for the virtio-blk support. v2 (Anmol): Add descriptive comments for serial in cell configuration files v3 (Anmol): Remove the ` IMAGE_INSTALL_append` and `EXTRA_IMAGE_FEATURES` from `50_local.conf.inc` v4 (Anmol): Minor changes in `50_local.conf.inc` v5 (jsmoeller): add meta-arm-toolchain to fix layer dependencies v6 (jsmoeller): remove linux-yocto_5.14%.bbappend v7 (Anmol): - Update the `SRCREV` for Jailhouse in `jailhous_git.bb` - Remove the patch `configs: arm64: Add support for RPi4 with more than 1G of memory` from `SRC_URI` in `jailhouse_git.bb` - Add the helper-scripts for the `runqemu-x86_64` and non-root linux cell. v8 (Anmol): Updated the `agl-ivshmem-demo.c`. v9 (Anmol): - Resolve build errors and update `jailhouse_git.bb`. - Add `PERF_forcevariable := "bash"` in `50_local.conf.inc`. v10 (Anmol): Disable perf build. v11 (jsmoeller): update qemu-agl.c to the 2G setup of runqemu after runtime test v12 (jsmoeller): add sample inmate tarball (to be used later) Change-Id: Idfa3e513488b5ecc8dfe9573f15c4b1c0edfd54f Signed-off-by: Anmol <anmol.karan123@gmail.com> Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb')
-rw-r--r--meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
index 462f0a77..cc75d684 100644
--- a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
+++ b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
@@ -10,22 +10,19 @@ LIC_FILES_CHKSUM = " \
file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \
"
-SRCREV = "4ce7658dddfd5a1682a379d5ac46657e93fe1ff0"
+SRCREV = "630001202caec85370fb4f956e581f51109e490c"
PV = "0.12+git${SRCPV}"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI = "git://github.com/siemens/jailhouse \
- file://0001-configs-arm64-Add-support-for-RPi4-with-more-than-1G.patch \
+ file://qemu-agl.c \
+ file://agl-apic-demo.c \
+ file://agl-pci-demo.c \
+ file://agl-ivshmem-demo.c \
+ file://agl-linux-x86-demo.c \
"
-SRC_URI += "file://qemu-agl.c \
- file://agl-apic-demo.c \
- file://agl-pci-demo.c \
- file://agl-ivshmem-demo.c \
- file://agl-linux-x86-demo.c \
- "
-
DEPENDS = "virtual/kernel dtc-native python3-mako-native make-native"
require jailhouse-arch.inc
@@ -42,22 +39,23 @@ DTS_DIR ?= "${JH_DATADIR}/cells/dts"
JH_CELL_FILES ?= "*.cell"
-EXTRA_OEMAKE = "ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" KDIR=${STAGING_KERNEL_BUILDDIR}"
+EXTRA_OEMAKE = "ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} -mfpmath=387" KDIR=${STAGING_KERNEL_BUILDDIR}"
do_configure() {
- # copy ${WORKDIR}/qemu-agl.c ${S}/configs/x86/ <--- folder where the cells are defined in the source tree to be compiled
- cp ${WORKDIR}/qemu-agl.c ${S}/configs/${JH_ARCH}
+ # copy ${WORKDIR}/<cell_config>.c ${S}/configs/x86/ <--- folder where the cells are defined in the source tree to be compiled
+ #cp ${WORKDIR}/qemu-agl.c ${S}/configs/${JH_ARCH}
cp ${WORKDIR}/agl-apic-demo.c ${S}/configs/x86/
- cp ${WORKDIR}/agl-pci-demo.c ${S}/configs/x86/
+ # cp ${WORKDIR}/agl-pci-demo.c ${S}/configs/x86/
cp ${WORKDIR}/agl-linux-x86-demo.c ${S}/configs/x86/
cp ${WORKDIR}/agl-ivshmem-demo.c ${S}/configs/x86/
+ cp ${WORKDIR}/qemu-agl.c ${S}/configs/x86/
sed -i '1s|^#!/usr/bin/env python$|#!/usr/bin/env python3|' ${B}/tools/${BPN}-*
}
do_compile() {
- oe_runmake
+ oe_runmake V=1
}
do_install() {
@@ -76,7 +74,6 @@ do_install() {
install -d ${D}${INMATES_DIR}
install -m 0644 ${B}/inmates/demos/${JH_ARCH}/*.bin ${D}${INMATES_DIR}
-
if [ ${JH_ARCH} != "x86" ]; then
install -d ${D}${DTS_DIR}
install -m 0644 ${B}/configs/${JH_ARCH}/dts/*.dtb ${D}${DTS_DIR}
@@ -89,6 +86,9 @@ FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
FILES_${PN}-tools = "${libexecdir}/${BPN}/${BPN}-* ${JH_DATADIR}/*.tmpl"
FILES_${PN}-demos = "${JH_DATADIR}/ ${sbindir}/ivshmem-demo"
+# Default Linker Hash Style Changed to "sysv"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
RDEPENDS_${PN}-tools = "pyjailhouse python3-mmap python3-math python3-datetime python3-curses python3-compression python3-mako"
RDEPENDS_pyjailhouse = "python3-core python3-ctypes python3-fcntl"
RDEPENDS_${PN}-demos = "jailhouse"