summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
diff options
context:
space:
mode:
authorParth Dode <dodecoder@gmail.com>2020-08-26 03:31:42 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-08-28 09:57:55 +0000
commit7e79247a82a7a04c4915c086f54612cfe67f0b67 (patch)
tree1f4bde6370bfc3ed552b86d350810a0eb39f1909 /meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
parent39872b4742c0f3868a9a4b1b16e2be66f0e754a5 (diff)
meta-agl-jailhouse: Enable jailhouse on qemu-x86_64 through runqemu
jailhouse enable /usr/share/jailhouse/cells/qemu-agl.cell added the appropriate QB variables required to use runqemu v2: updated QB_SERIAL_OPT v3: updated do_configure and do_install v4: updated memmap v5: resolved comments v6: 2G to 1G Bug-AGL: SPEC-3507 Change-Id: Iae8cf6a1f27bc285e4c0c5f2518cd1985ddf3b74 Signed-off-by: Parth Dode <dodecoder@gmail.com>
Diffstat (limited to 'meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb')
-rw-r--r--meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
index 2fbd68e3..cb7e48c0 100644
--- a/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
+++ b/meta-agl-jailhouse/recipes-extended/jailhouse/jailhouse_git.bb
@@ -38,6 +38,10 @@ JH_CELL_FILES ?= "*.cell"
EXTRA_OEMAKE = "ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" KDIR=${STAGING_KERNEL_BUILDDIR}"
do_configure() {
+
+ # copy ${WORKDIR}/qemu-agl.c ${S}/configs/x86/ <--- folder where the cells are defined in the source tree to be compiled
+ cp ${WORKDIR}/qemu-agl.c ${S}/configs/${JH_ARCH}
+
sed -i '1s|^#!/usr/bin/env python$|#!/usr/bin/env python3|' ${B}/tools/${BPN}-*
}
@@ -55,6 +59,8 @@ do_install() {
oe_runmake PIP=: PYTHON=python3 PYTHON_PIP_USEABLE=yes DESTDIR=${D} install
install -d ${D}${CELL_DIR}
+
+
install -m 0644 ${B}/configs/${JH_ARCH}/${JH_CELL_FILES} ${D}${CELL_DIR}/
install -d ${D}${INMATES_DIR}