summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/recipes-kernel
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
commit37d3b1b316470fdcfebc59d5522bfbfefc025ff6 (patch)
treecf70d6c9e3832d8734de4f66f2d0fe52b104c9fd /meta-agl-jailhouse/recipes-kernel
parentab5f7f52dbdbea04d1f79310cbf08922a5371345 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0bbae97331abee1367b368ce54ab39e3162a12ec
Diffstat (limited to 'meta-agl-jailhouse/recipes-kernel')
-rw-r--r--meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb10
-rw-r--r--meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc4
-rw-r--r--meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb2
3 files changed, 8 insertions, 8 deletions
diff --git a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb
index f207a43c..8a6e4903 100644
--- a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb
+++ b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/kernel-devsrc.bb
@@ -270,11 +270,11 @@ do_install() {
# Ensure we don't race against "make scripts" during cpio
do_install[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
-FILES_${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
-FILES_${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
+FILES:${PN} = "${KERNEL_BUILD_ROOT} ${KERNEL_SRC_PATH}"
+FILES:${PN}-dbg += "${KERNEL_BUILD_ROOT}*/build/scripts/*/.debug/*"
-RDEPENDS_${PN} = "bc python3 flex bison ${TCLIBC}-utils"
+RDEPENDS:${PN} = "bc python3 flex bison ${TCLIBC}-utils"
# 4.15+ needs these next two RDEPENDS
-RDEPENDS_${PN} += "openssl-dev util-linux"
+RDEPENDS:${PN} += "openssl-dev util-linux"
# and x86 needs a bit more for 4.15+
-RDEPENDS_${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
+RDEPENDS:${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
diff --git a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc
index 2807563d..7cc70c07 100644
--- a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc
+++ b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-5.14.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux:"
-SRC_URI_append = " file://jailhouse.cfg"
+SRC_URI:append = " file://jailhouse.cfg"
diff --git a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb
index 6eb55e46..0e5818a2 100644
--- a/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb
+++ b/meta-agl-jailhouse/recipes-kernel/linux-jailhouse-custom/linux-jailhouse-custom_git.bb
@@ -20,4 +20,4 @@ PV = "5.14-rc2+git${SRCPV}"
KVER = "5.14"
DEPENDS += "ncurses-native bc-native pkgconfig-native"
-DEPENDS_append_x86-64 = " elfutils-native"
+DEPENDS:append:x86-64 = " elfutils-native"