summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
diff options
context:
space:
mode:
authorHiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com>2022-07-14 16:23:37 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-07-25 17:05:23 +0000
commitf206eab5753bd9ee2d5b1126c6ec5a18e75cac89 (patch)
tree77878be5d00f35abc4490a4d34472ab492bf531b /meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
parent50f6b56d091d5d5a6c37910a0470f62bf5f72776 (diff)
agl-lxc: Enable network bridge via lxc-net
On lxc-host-image-demo, network (physical ethernet) is statically assigned to the ivi-guest space currently. This may be a bit problematic since the other guests and also host can't use network for some future usecases, for example we can't login to host by ssh. This change enables network bridge settings via lxc-net to solve this problem. Bug-AGL: SPEC-4475 Signed-off-by: Hiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com> Change-Id: Ic1a39b64de932f67b7be833d469ef1a80e0c52c9
Diffstat (limited to 'meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend')
-rw-r--r--meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend b/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
index b8456f7f..75ab98c0 100644
--- a/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
+++ b/meta-agl-lxc/recipes-container/lxc/lxc_%.bbappend
@@ -4,11 +4,16 @@ SYSTEMD_AUTO_ENABLE:${PN} = "enable"
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI += "file://lxc.service"
+SRC_URI += " \
+ file://lxc.service \
+ file://lxc-net.service \
+ "
do_install:append () {
- install -D -m 0644 ${WORKDIR}/lxc.service ${D}${systemd_system_unitdir}/lxc.service
- sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_system_unitdir}/lxc.service
+ for service in lxc.service lxc-net.service; do
+ install -D -m 0644 ${WORKDIR}/$service ${D}${systemd_system_unitdir}/$service
+ sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_system_unitdir}/$service
+ done
}
# NOTE: