summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-13 07:06:06 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-17 15:42:36 +0000
commite2954337aee949935000ac81789ee8f550f0b130 (patch)
treeda18245b271b413f9513525d0c6ab895e8a645fd /meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb
parent2fee5c5e668ceeb20b1e2c5f90ad6308149863cc (diff)
Enable network connection in ivi guest
In ivi guest, must require to internet connections. This patch enable network connection in ivi guest. Detaille: Bind eth0 device to ivi guest. Enable systemd-networkd to manage network connection. Add network interface setting to set IP address using dhcp. Bug-AGL: SPEC-4132 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: Icf0fb386d1efafb060a66e0cab727f93d5e8e7fd
Diffstat (limited to 'meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb')
-rw-r--r--meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb b/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb
new file mode 100644
index 00000000..cd34dc75
--- /dev/null
+++ b/meta-agl-lxc/recipes-core/systemd/systemd-netif-config_0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Systemd network interface configuration"
+DESCRIPTION = "Systemd network interface configuration \
+ "
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = " \
+ file://20-wired.network \
+ "
+
+do_install() {
+ install -D -m0644 ${WORKDIR}/20-wired.network ${D}/etc/systemd/network/20-wired.network
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES:${PN} = "\
+ /etc/systemd/network/* \
+"