summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-11 19:44:45 -0400
committerScott Murray <scott.murray@konsulko.com>2022-04-11 19:44:45 -0400
commit42422ac20922a3fa2a6f1ab7c08a25b22769b44a (patch)
tree78d0fce5867b4a6575a308daf7090529a4ae4e75 /meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
parenta61f829fb16aeb4df245a186169ae7326ac0607a (diff)
Fix remaining use of old override syntax
Some usage of the old override syntax crept back in with recent commits, fix those so that building with kirkstone is feasible. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2293a2ad463c52022e2f3f052719dca59b404d6b
Diffstat (limited to 'meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb')
-rw-r--r--meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
index 12f14c84..209cd978 100644
--- a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
+++ b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
@@ -9,7 +9,7 @@ PV = "0.1.0+rev${SRCPV}"
SRCREV = "e3a33d47195e4656f7117753d27a0f2d6b21aab9"
SRC_URI = " \
- git://github.com/AGLExport/ilm-manager.git;protocol=https \
+ git://github.com/AGLExport/ilm-manager.git;branch=master;protocol=https \
file://agl.json \
file://ilm-manager.service \
"
@@ -17,7 +17,7 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig systemd
-do_install_append() {
+do_install:append() {
#install scripts
install -d ${D}/etc
install -m 0644 ${WORKDIR}/agl.json ${D}/etc
@@ -26,6 +26,6 @@ do_install_append() {
install -m 0644 ${WORKDIR}/ilm-manager.service ${D}/lib/systemd/system
}
-FILES_${PN} += " ${systemd_unitdir} /etc/* "
+FILES:${PN} += " ${systemd_unitdir} /etc/* "
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "ilm-manager.service"
+SYSTEMD_SERVICE:${PN} = "ilm-manager.service"