summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-10-04 15:50:40 +0900
committerNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2021-11-16 01:06:19 +0900
commit2a78ef2ac8403b3f86a3c077d20b43eeb16c295e (patch)
tree334917150fde7d48397a820c977fbbb65508c8f7 /meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
parentaeebf4152989fceccefa2b55cbb5f30e1ba7988d (diff)
Importing the mediaplayer demo app
The momiplay is a mediaplayer example based on AGL sample app at CC release. Existing agl-appfw is difficult to integrate into linux container guest, because agl-appfw strongly depend SMACK label in host. The mominavi is not require agl-appfw. It's temporally solution for MM release. This patch import momiplay to create ivi guest for demo. Bug-AGL: SPEC-4094 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Change-Id: Ic0213f50ba570db56282d07b3f4f775664f05f78
Diffstat (limited to 'meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb')
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb b/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
new file mode 100644
index 00000000..94e4afc6
--- /dev/null
+++ b/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Momiyama mediaplayer example based on AGL sample app. at CC"
+DESCRIPTION = "The momiplay is a mediaplayer example based on AGL sample app. \
+ The momiplay is not require agl-appfw."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=17;md5=f4ad6901289f57f62d15bfefb5cc3633"
+
+PV = "0.2.0"
+
+inherit qmake5 systemd
+
+DEPENDS = "qtbase qtquickcontrols2 qtgraphicaleffects qtsvg qtmultimedia "
+RDEPENDS_${PN} = "qtsvg qtmultimedia "
+
+SRC_URI = "git://github.com/AGLExport/momiplayer.git;protocol=https \
+ file://momiplay.service \
+ file://momiplay \
+ "
+SRCREV = "b4715bf924ea295feaaf8fbdb4a9c3da75f57591"
+
+S = "${WORKDIR}/git"
+
+QT_INSTALL_PREFIX = "/usr"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "momiplay.service"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+
+do_install_append() {
+ install -d ${D}/lib/systemd/system
+ install -m 0644 ${WORKDIR}/momiplay.service ${D}/lib/systemd/system
+
+ install -m 0755 -d ${D}${sysconfdir}/default/
+ install -m 0755 ${WORKDIR}/momiplay ${D}${sysconfdir}/default/
+}
+
+FILES_${PN} += " ${systemd_unitdir} ${sysconfdir}/*/* "