summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-demo
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
committerScott Murray <scott.murray@konsulko.com>2021-11-17 14:19:36 -0500
commita8dbd14daaac8b5c52326262dbc43975836cc0df (patch)
treee52e3eaaa084ddf2d3fb44158cd0f2d5c9140178 /meta-agl-lxc/recipes-demo
parentf9dcc4101b86d14f583319786286a72b63cbbc98 (diff)
Convert to new override syntax
This is effectively a manual cherry-pick of commit: 37d3b1b316470fdcfebc59d5522bfbfefc025ff6 from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ic649d942ac043edc52976a3d4190590bb1c125e7
Diffstat (limited to 'meta-agl-lxc/recipes-demo')
-rw-r--r--meta-agl-lxc/recipes-demo/refgui/refgui_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb b/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb
index 0edf7890..9d758dce 100644
--- a/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb
+++ b/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb
@@ -24,16 +24,16 @@ inherit cmake cmake_qt5 systemd
APP_DIR = "/opt/apps"
EXTRA_OECMAKE = "-DAPPS_INST_DIR=${APP_DIR}"
-SYSTEMD_SERVICE_${PN} = "cluster.service"
+SYSTEMD_SERVICE:${PN} = "cluster.service"
-do_install_append() {
+do_install:append() {
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/cluster.service ${D}${systemd_unitdir}/system/
}
-FILES_${PN} += "${APP_DIR}/"
+FILES:${PN} += "${APP_DIR}/"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
qtbase \
qtdeclarative \
qt3d \