summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc/recipes-demo
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 11:33:17 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-08-09 15:45:17 +0200
commit68fa652a418a5dfcee12386fd58939bfd626144d (patch)
tree35db36536266979f085683985f5f0e5249df8e1f /meta-agl-lxc/recipes-demo
parent17087e4083b2b6b070cec55c38288644689fa55c (diff)
Rename Instrument Cluster Container layerneedlefish_14.0.0needlefish/14.0.014.0.0
meta-agl-lxc is no longer reflecting the actual content and use of the layer. Rename it to 'meta-agl-ic-container' and the feature to 'agl-ic-container'. Also rename the main image to 'agl-cluster-demo-lxc-host' to match the pattern used by all other images e.g. agl-<ivi,cluster,telematics>-demo-* . But keep the names of the underlying images as-is. Bug-AGL: SPEC-4464 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I898c786ca884331b302a3be8e150379fcf5bdc9b
Diffstat (limited to 'meta-agl-lxc/recipes-demo')
-rw-r--r--meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster5
-rw-r--r--meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster.service11
-rw-r--r--meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui_git.bb49
-rw-r--r--meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json70
-rw-r--r--meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service12
-rw-r--r--meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb31
-rw-r--r--meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi7
-rw-r--r--meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi.service12
-rw-r--r--meta-agl-lxc/recipes-demo/mominavi/mominavi_git.bb57
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay8
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service12
-rw-r--r--meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb48
-rw-r--r--meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen8
-rw-r--r--meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service12
-rw-r--r--meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb43
15 files changed, 0 insertions, 385 deletions
diff --git a/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster b/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster
deleted file mode 100644
index ff5166d0..00000000
--- a/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster
+++ /dev/null
@@ -1,5 +0,0 @@
-XDG_RUNTIME_DIR=/run/user/0
-QT_QPA_PLATFORM=wayland-egl
-QT_WAYLAND_DISABLE_WINDOWDECORATION=1
-QT_QPA_FONTDIR=/usr/share/fonts/truetype
-WAYLAND_DISPLAY=wayland-1
diff --git a/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster.service b/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster.service
deleted file mode 100644
index a82c4127..00000000
--- a/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui/cluster.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=AGL Cluster Reference GUI
-After=multi-user.target weston.service
-Requires=multi-user.target weston.service
-
-[Service]
-EnvironmentFile=/etc/default/cluster
-ExecStart=/opt/apps/cluster
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui_git.bb b/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui_git.bb
deleted file mode 100644
index 4327c8de..00000000
--- a/meta-agl-lxc/recipes-demo/cluster-refgui/cluster-refgui_git.bb
+++ /dev/null
@@ -1,49 +0,0 @@
-DESCRIPTION = "AGL Cluster Reference GUI"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5335066555b14d832335aa4660d6c376"
-
-DEPENDS = " \
- qttools-native \
- qtmultimedia \
-"
-
-BRANCH = "master"
-SRC_URI = "git://git.automotivelinux.org/src/cluster-refgui;protocol=https;branch=${BRANCH} \
- file://cluster.service \
- file://cluster \
-"
-SRCREV = "a16c6201be94a57eb8151a91699084d99694877c"
-
-S = "${WORKDIR}/git"
-
-inherit cmake cmake_qt5 systemd
-
-# NOTE:
-# The app currently assumes the mp4 video file is in the same
-# directory, so changing this to ${bindir} to better match FHS
-# requires code changes.
-APP_DIR = "/opt/apps"
-EXTRA_OECMAKE = "-DAPPS_INST_DIR=${APP_DIR}"
-
-SYSTEMD_SERVICE:${PN} = "cluster.service"
-
-do_install:append() {
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/cluster.service ${D}${systemd_unitdir}/system/
-
- install -m 0755 -d ${D}${sysconfdir}/default/
- install -m 0755 ${WORKDIR}/cluster ${D}${sysconfdir}/default/
-}
-
-FILES:${PN} += "${APP_DIR}/"
-
-RDEPENDS:${PN} = " \
- qtbase \
- qtdeclarative \
- qt3d \
- qtgraphicaleffects \
- qtmultimedia \
- qtquickcontrols \
- qtquickcontrols2 \
- qtwayland \
-"
diff --git a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json
deleted file mode 100644
index 80028c50..00000000
--- a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/agl.json
+++ /dev/null
@@ -1,70 +0,0 @@
-{
- "screen": [
- {
- "name": "ivi-screen",
- "dispname": "HDMI-A-1"
- }
- ],
- "layer": [
- {
- "name": "ivi-layer",
- "id": 2000,
- "width": 1920,
- "height": 1080,
- "x": 0,
- "y": 0,
- "z": 10,
- "attach": "ivi-screen"
- }
- ],
- "surface": [
- {
- "name": "momiscreen",
- "id": 2000,
- "x": 0,
- "y": 988,
- "z": 10,
- "attach": "ivi-layer"
- },
- {
- "name": "mominavi",
- "id": 2010,
- "x": 0,
- "y": 0,
- "z": 100,
- "attach": "ivi-layer"
- },
- {
- "name": "momiplay",
- "id": 2011,
- "x": 0,
- "y": 0,
- "z": 110,
- "attach": "ivi-layer"
- },
- {
- "name": "momiradio",
- "id": 2012,
- "x": 0,
- "y": 0,
- "z": 120,
- "attach": "ivi-layer"
- },
- {
- "name": "momisetting",
- "id": 2013,
- "x": 0,
- "y": 0,
- "z": 130,
- "attach": "ivi-layer"
- },
- {
- "name": "xdg-test",
- "id": 9801,
- "x": 0,
- "y": 0,
- "z": 300,
- "attach": "ivi-layer"
- }
- ]
-}
diff --git a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service
deleted file mode 100644
index b91b65f1..00000000
--- a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager/ilm-manager.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Tiny Window Manager
-After=weston.service
-Wants=weston.service
-
-[Service]
-Type=simple
-EnvironmentFile=/etc/default/weston
-ExecStart=/usr/bin/ilmmanager
-
-[Install]
-WantedBy=weston.service
diff --git a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb b/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
deleted file mode 100644
index 2f976b39..00000000
--- a/meta-agl-lxc/recipes-demo/ilm-manager/ilm-manager_git.bb
+++ /dev/null
@@ -1,31 +0,0 @@
-SUMMARY = "Tiny window manager for wayland-ivi-extension"
-DESCRIPTION = "Tiny window manager for wayland-ivi-extension"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-DEPENDS = "jsoncpp wayland-ivi-extension"
-
-PV = "0.1.0+rev${SRCPV}"
-
-SRCREV = "e3a33d47195e4656f7117753d27a0f2d6b21aab9"
-SRC_URI = " \
- git://github.com/AGLExport/ilm-manager.git;branch=master;protocol=https \
- file://agl.json \
- file://ilm-manager.service \
- "
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig systemd
-
-do_install:append() {
- #install scripts
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/agl.json ${D}${sysconfdir}
-
- install -d ${D}/${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/ilm-manager.service ${D}${systemd_system_unitdir}
-}
-
-FILES:${PN} += " ${systemd_system_unitdir} ${sysconfdir} "
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "ilm-manager.service"
diff --git a/meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi b/meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi
deleted file mode 100644
index bd017dc9..00000000
--- a/meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi
+++ /dev/null
@@ -1,7 +0,0 @@
-XDG_RUNTIME_DIR=/run/user/0
-QT_QPA_PLATFORM=wayland-egl
-QT_WAYLAND_DISABLE_WINDOWDECORATION=1
-QT_QPA_FONTDIR=/usr/share/fonts/truetype
-QT_IVI_SURFACE_ID=2010
-QT_WAYLAND_SHELL_INTEGRATION=ivi-shell
-WAYLAND_DISPLAY=wayland-1
diff --git a/meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi.service b/meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi.service
deleted file mode 100644
index b49609e0..00000000
--- a/meta-agl-lxc/recipes-demo/mominavi/mominavi/mominavi.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=mominavi
-After=multi-user.target weston.service network-online.target
-Requires=multi-user.target weston.service network-online.target
-
-[Service]
-Type=simple
-EnvironmentFile=/etc/default/mominavi
-ExecStart=/usr/bin/mominavi
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl-lxc/recipes-demo/mominavi/mominavi_git.bb b/meta-agl-lxc/recipes-demo/mominavi/mominavi_git.bb
deleted file mode 100644
index 124252b5..00000000
--- a/meta-agl-lxc/recipes-demo/mominavi/mominavi_git.bb
+++ /dev/null
@@ -1,57 +0,0 @@
-SUMMARY = "Momiyama navigation example based on mapbox."
-DESCRIPTION = "The mominavi is a navigation example based on mapbox. It's based on aglqtnavigation. \
- The mominavi is not require agl-appfw."
-LICENSE = "GPL-3.0-only"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
-
-DEPENDS = " \
- qtbase \
- qtquickcontrols2 \
- qtlocation \
- qtgraphicaleffects \
- qtsvg \
- qtwebsockets \
- "
-
-PV = "0.2.0"
-
-SRC_URI = "git://github.com/AGLExport/mominavi.git;protocol=https;branch=master \
- file://mominavi.service \
- file://mominavi \
- "
-SRCREV = "553776e75da02b27224748756da55d38b6c7241f"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5 systemd
-
-MOMIMAP_MAPBOX_ACCESS_TOKEN ??= "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF"
-QT_INSTALL_PREFIX = "/usr"
-
-do_configure:prepend() {
- if [ "${MOMIMAP_MAPBOX_ACCESS_TOKEN}" = "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF" ]; then
- bbwarn "WARNING: You should set MapBox development key to MOMIMAP_MAPBOX_ACCESS_TOKEN variable in local.conf."
- fi
-}
-do_install:append() {
- install -d ${D}/${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/mominavi.service ${D}/${systemd_unitdir}/system
-
- install -m 0755 -d ${D}${sysconfdir}/default/
- install -m 0755 ${WORKDIR}/mominavi ${D}${sysconfdir}/default/
-
- echo 'MOMIMAP_MAPBOX_ACCESS_TOKEN=${MOMIMAP_MAPBOX_ACCESS_TOKEN}' >> ${D}${sysconfdir}/default/mominavi
-}
-
-FILES:${PN} += " \
- ${systemd_unitdir} \
- ${sysconfdir}/*/* \
- "
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "mominavi.service"
-
-RDEPENDS:${PN} = " \
- qtsvg \
- qtwebsockets \
- qtlocation \
- "
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay b/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay
deleted file mode 100644
index be5a97a1..00000000
--- a/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay
+++ /dev/null
@@ -1,8 +0,0 @@
-XDG_RUNTIME_DIR=/run/user/0
-QT_QPA_PLATFORM=wayland-egl
-QT_WAYLAND_DISABLE_WINDOWDECORATION=1
-QT_QPA_FONTDIR=/usr/share/fonts/truetype
-QT_IVI_SURFACE_ID=2011
-QT_WAYLAND_SHELL_INTEGRATION=ivi-shell
-WAYLAND_DISPLAY=wayland-1
-HOME=/home/root
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service b/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service
deleted file mode 100644
index ef974023..00000000
--- a/meta-agl-lxc/recipes-demo/momiplay/momiplay/momiplay.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=momiplayer
-After=multi-user.target weston.service
-Requires=multi-user.target weston.service
-
-[Service]
-Type=simple
-EnvironmentFile=/etc/default/momiplay
-ExecStart=/usr/bin/momiplay
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb b/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
deleted file mode 100644
index 02fc6f66..00000000
--- a/meta-agl-lxc/recipes-demo/momiplay/momiplay_git.bb
+++ /dev/null
@@ -1,48 +0,0 @@
-SUMMARY = "Momiyama mediaplayer example based on AGL sample app. at CC"
-DESCRIPTION = "The momiplay is a mediaplayer example based on AGL sample app. \
- The momiplay is not require agl-appfw."
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://main.cpp;beginline=1;endline=17;md5=f4ad6901289f57f62d15bfefb5cc3633"
-
-DEPENDS = " \
- qtbase \
- qtquickcontrols2 \
- qtgraphicaleffects \
- qtsvg \
- qtmultimedia \
- "
-
-PV = "0.2.0"
-
-SRC_URI = "git://github.com/AGLExport/momiplayer.git;protocol=https;branch=master \
- file://momiplay.service \
- file://momiplay \
- "
-SRCREV = "b4715bf924ea295feaaf8fbdb4a9c3da75f57591"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5 systemd
-
-QT_INSTALL_PREFIX = "/usr"
-
-do_install:append() {
- install -d ${D}/${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/momiplay.service ${D}/${systemd_unitdir}/system
-
- install -m 0755 -d ${D}${sysconfdir}/default/
- install -m 0755 ${WORKDIR}/momiplay ${D}${sysconfdir}/default/
-}
-
-FILES:${PN} += " \
- ${systemd_unitdir} \
- ${sysconfdir}/*/* \
- "
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "momiplay.service"
-SYSTEMD_AUTO_ENABLE:${PN} = "disable"
-
-RDEPENDS:${PN} = " \
- qtsvg \
- qtmultimedia \
- "
diff --git a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen
deleted file mode 100644
index 2c0e461c..00000000
--- a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen
+++ /dev/null
@@ -1,8 +0,0 @@
-XDG_RUNTIME_DIR=/run/user/0
-QT_QPA_PLATFORM=wayland-egl
-QT_WAYLAND_DISABLE_WINDOWDECORATION=1
-QT_QPA_FONTDIR=/usr/share/fonts/truetype
-QT_IVI_SURFACE_ID=2000
-QT_WAYLAND_SHELL_INTEGRATION=ivi-shell
-WAYLAND_DISPLAY=wayland-1
-HOME=/home/root
diff --git a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service
deleted file mode 100644
index a3f54e0c..00000000
--- a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen/momiscreen.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=momiscreen
-After=multi-user.target weston.service
-Requires=multi-user.target weston.service
-
-[Service]
-Type=simple
-EnvironmentFile=/etc/default/momiscreen
-ExecStart=/usr/bin/momiscreen
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb b/meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb
deleted file mode 100644
index f37a5365..00000000
--- a/meta-agl-lxc/recipes-demo/momiscreen/momiscreen_git.bb
+++ /dev/null
@@ -1,43 +0,0 @@
-SUMMARY = "Momiyama home screen example"
-DESCRIPTION = "The momiscreen is a home screen example. \
- The momiscreen is not require agl-appfw."
-LICENSE = "GPL-3.0-only"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
-
-DEPENDS = " \
- qtbase \
- qtquickcontrols2 \
- qtgraphicaleffects \
- qtsvg \
- "
-
-PV = "0.2.0"
-
-SRC_URI = "git://github.com/AGLExport/momiscreen.git;protocol=https;branch=main \
- file://momiscreen.service \
- file://momiscreen \
- "
-SRCREV = "bc3ef09ffad15b97941f28b165dc2019f5950105"
-
-S = "${WORKDIR}/git"
-
-inherit qmake5 systemd
-
-QT_INSTALL_PREFIX = "/usr"
-
-do_install:append() {
- install -d ${D}/${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/momiscreen.service ${D}/${systemd_unitdir}/system
-
- install -m 0755 -d ${D}${sysconfdir}/default/
- install -m 0755 ${WORKDIR}/momiscreen ${D}${sysconfdir}/default/
-}
-
-FILES:${PN} += " \
- ${systemd_unitdir} \
- ${sysconfdir}/*/* \
- "
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "momiscreen.service"
-
-RDEPENDS:${PN} = "qtsvg "