summaryrefslogtreecommitdiffstats
path: root/meta-agl-lxc
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
commit37d3b1b316470fdcfebc59d5522bfbfefc025ff6 (patch)
treecf70d6c9e3832d8734de4f66f2d0fe52b104c9fd /meta-agl-lxc
parentab5f7f52dbdbea04d1f79310cbf08922a5371345 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0bbae97331abee1367b368ce54ab39e3162a12ec
Diffstat (limited to 'meta-agl-lxc')
-rw-r--r--meta-agl-lxc/classes/lxc-config.bbclass4
-rw-r--r--meta-agl-lxc/conf/multiconfig/agl-container-guest.conf16
-rw-r--r--meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-connectivity/openssl/openssl_1.1.%.bbappend2
-rw-r--r--meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend2
-rw-r--r--meta-agl-lxc/recipes-container/lxc/lxc_4.%.bbappend6
-rw-r--r--meta-agl-lxc/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend8
-rw-r--r--meta-agl-lxc/recipes-demo/refgui/refgui_git.bb8
-rw-r--r--meta-agl-lxc/recipes-graphics/wayland/weston-ini-conf.bbappend2
-rw-r--r--meta-agl-lxc/recipes-graphics/wayland/weston-init.bbappend10
-rw-r--r--meta-agl-lxc/recipes-kernel/linux/linux_lxc.inc2
-rw-r--r--meta-agl-lxc/recipes-multimedia/pipewire-ic-ipc/pipewire-ic-ipc_git.bb6
-rw-r--r--meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb2
-rw-r--r--meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb2
-rw-r--r--meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb2
14 files changed, 36 insertions, 36 deletions
diff --git a/meta-agl-lxc/classes/lxc-config.bbclass b/meta-agl-lxc/classes/lxc-config.bbclass
index 1aefccdc..a3bdf802 100644
--- a/meta-agl-lxc/classes/lxc-config.bbclass
+++ b/meta-agl-lxc/classes/lxc-config.bbclass
@@ -29,7 +29,7 @@ inherit allarch
DRM_LEASE_DEVICE ??= "card0-HDMI-A-1"
-DRM_LEASE_DEVICE_qemuall ?= "card0-Virtual-1"
+DRM_LEASE_DEVICE:qemuall ?= "card0-Virtual-1"
LXC_AUTO_START ??= "0"
@@ -45,4 +45,4 @@ do_install () {
done
}
-FILES_${PN} = "${localstatedir}/lib/lxc/"
+FILES:${PN} = "${localstatedir}/lib/lxc/"
diff --git a/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf b/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf
index 1e2e932d..cf5320e9 100644
--- a/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf
+++ b/meta-agl-lxc/conf/multiconfig/agl-container-guest.conf
@@ -1,23 +1,23 @@
-OVERRIDES_append = ":aglcontainerguest"
+OVERRIDES:append = ":aglcontainerguest"
TMPDIR = "${TOPDIR}/tmp-${BB_CURRENT_MC}"
# Can be blank as container image type results in a .tar.bz2
-AGL_DEFAULT_IMAGE_FSTYPES_aglcontainerguest = ""
-AGL_EXTRA_IMAGE_FSTYPES_aglcontainerguest = ""
+AGL_DEFAULT_IMAGE_FSTYPES:aglcontainerguest = ""
+AGL_EXTRA_IMAGE_FSTYPES:aglcontainerguest = ""
-IMAGE_FSTYPES_aglcontainerguest = "container"
+IMAGE_FSTYPES:aglcontainerguest = "container"
-IMAGE_LINGUAS_append_aglcontainerguest = " en-us"
+IMAGE_LINGUAS:append:aglcontainerguest = " en-us"
PREFERRED_PROVIDER_virtual/kernel_aglcontainerguest = "linux-dummy"
-KERNEL_DEVICETREE_aglcontainerguest = ""
+KERNEL_DEVICETREE:aglcontainerguest = ""
# Disable serial consoles
-SERIAL_CONSOLES_aglcontainerguest = ""
+SERIAL_CONSOLES:aglcontainerguest = ""
# Remove unneeded firmware packages
-EXTRA_IMAGEDEPENDS_remove_aglcontainerguest = "arm-trusted-firmware optee-os u-boot"
+EXTRA_IMAGEDEPENDS:remove:aglcontainerguest = "arm-trusted-firmware optee-os u-boot"
# We assume rngd is running on the host, so unnecessary in container
VIRTUAL-RUNTIME_rngd = ""
diff --git a/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-connectivity/openssl/openssl_1.1.%.bbappend b/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-connectivity/openssl/openssl_1.1.%.bbappend
index e30136f2..6060e6b1 100644
--- a/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-connectivity/openssl/openssl_1.1.%.bbappend
+++ b/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-connectivity/openssl/openssl_1.1.%.bbappend
@@ -1,4 +1,4 @@
# Add a hook to disable depending on cryptodev-module for containers
CRYPTODEV_RDEPENDS = "cryptodev-module"
-CRYPTODEV_RDEPENDS_aglcontainerguest = ""
+CRYPTODEV_RDEPENDS:aglcontainerguest = ""
PACKAGECONFIG[cryptodev-linux] = "enable-devcryptoeng,disable-devcryptoeng,cryptodev-linux,,${CRYPTODEV_RDEPENDS}"
diff --git a/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend b/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend
index 41cdea3b..c942f687 100644
--- a/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend
+++ b/meta-agl-lxc/dynamic-layers/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend
@@ -1 +1 @@
-RDEPENDS_${PN}_remove_aglcontainerguest = "kernel-module-gles"
+RDEPENDS:${PN}:remove:aglcontainerguest = "kernel-module-gles"
diff --git a/meta-agl-lxc/recipes-container/lxc/lxc_4.%.bbappend b/meta-agl-lxc/recipes-container/lxc/lxc_4.%.bbappend
index 61dfa665..72078495 100644
--- a/meta-agl-lxc/recipes-container/lxc/lxc_4.%.bbappend
+++ b/meta-agl-lxc/recipes-container/lxc/lxc_4.%.bbappend
@@ -1,11 +1,11 @@
-PACKAGECONFIG_remove = "templates"
+PACKAGECONFIG:remove = "templates"
-SYSTEMD_AUTO_ENABLE_${PN} = "enable"
+SYSTEMD_AUTO_ENABLE:${PN} = "enable"
# NOTE:
# This needs to be replaced with a rework of the upstream packaging
# to do a proper split of core from the template support.
-RDEPENDS_${PN} = ""
+RDEPENDS:${PN} = ""
diff --git a/meta-agl-lxc/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/meta-agl-lxc/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
index 892ac7b1..13f85b59 100644
--- a/meta-agl-lxc/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
+++ b/meta-agl-lxc/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
@@ -1,8 +1,8 @@
# Disable LTTng dependencies when building for container guest to avoid
# lttng-modules being pulled in as a dependency.
-LTTNGUST_aglcontainerguest = ""
-LTTNGTOOLS_aglcontainerguest = ""
-LTTNGMODULES_aglcontainerguest = ""
+LTTNGUST:aglcontainerguest = ""
+LTTNGTOOLS:aglcontainerguest = ""
+LTTNGMODULES:aglcontainerguest = ""
# Similarly, disable perf since it builds out of the kernel source tree.
-PERF_aglcontainerguest = ""
+PERF:aglcontainerguest = ""
diff --git a/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb b/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb
index 0edf7890..9d758dce 100644
--- a/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb
+++ b/meta-agl-lxc/recipes-demo/refgui/refgui_git.bb
@@ -24,16 +24,16 @@ inherit cmake cmake_qt5 systemd
APP_DIR = "/opt/apps"
EXTRA_OECMAKE = "-DAPPS_INST_DIR=${APP_DIR}"
-SYSTEMD_SERVICE_${PN} = "cluster.service"
+SYSTEMD_SERVICE:${PN} = "cluster.service"
-do_install_append() {
+do_install:append() {
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/cluster.service ${D}${systemd_unitdir}/system/
}
-FILES_${PN} += "${APP_DIR}/"
+FILES:${PN} += "${APP_DIR}/"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
qtbase \
qtdeclarative \
qt3d \
diff --git a/meta-agl-lxc/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-lxc/recipes-graphics/wayland/weston-ini-conf.bbappend
index 00057874..46dfc124 100644
--- a/meta-agl-lxc/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-lxc/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1,2 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
diff --git a/meta-agl-lxc/recipes-graphics/wayland/weston-init.bbappend b/meta-agl-lxc/recipes-graphics/wayland/weston-init.bbappend
index 9951b2b3..4374c455 100644
--- a/meta-agl-lxc/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl-lxc/recipes-graphics/wayland/weston-init.bbappend
@@ -1,18 +1,18 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
AGL_DEFAULT_WESTONSTART ??= "/usr/bin/weston --config ${sysconfdir}/xdg/weston/weston.ini"
WESTONARGS ?= "--idle-time=0 --drm-lease=\${DRM_LEASE_DEVICE}"
WESTONSTART ??= "${AGL_DEFAULT_WESTONSTART} ${WESTONARGS}"
-WESTONSTART_append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", " --debug", "",d)}"
+WESTONSTART:append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", " --debug", "",d)}"
WIFILES = " \
file://drm-lease.conf.in \
"
-SRC_URI_append = " ${WIFILES}"
+SRC_URI:append = " ${WIFILES}"
-do_install_append() {
+do_install:append() {
# Process ".in" files
files=$(echo ${WIFILES} | sed s,file://,,g)
for f in ${files}; do
@@ -35,6 +35,6 @@ do_install_append() {
ln -s ../weston@.service ${D}${systemd_system_unitdir}/multi-user.target.wants/weston@root.service
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${systemd_system_unitdir}/ \
"
diff --git a/meta-agl-lxc/recipes-kernel/linux/linux_lxc.inc b/meta-agl-lxc/recipes-kernel/linux/linux_lxc.inc
index f123f6d9..327beb18 100644
--- a/meta-agl-lxc/recipes-kernel/linux/linux_lxc.inc
+++ b/meta-agl-lxc/recipes-kernel/linux/linux_lxc.inc
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux:"
# Disable all other AGL provided kernel configuration (barring
# base BSP provided configuration), and just enable a locally
diff --git a/meta-agl-lxc/recipes-multimedia/pipewire-ic-ipc/pipewire-ic-ipc_git.bb b/meta-agl-lxc/recipes-multimedia/pipewire-ic-ipc/pipewire-ic-ipc_git.bb
index 2951d0e9..27f6bfc5 100644
--- a/meta-agl-lxc/recipes-multimedia/pipewire-ic-ipc/pipewire-ic-ipc_git.bb
+++ b/meta-agl-lxc/recipes-multimedia/pipewire-ic-ipc/pipewire-ic-ipc_git.bb
@@ -19,7 +19,7 @@ PACKAGECONFIG = "\
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
"
# only the example client in the guest
-PACKAGECONFIG_aglcontainerguest = "client"
+PACKAGECONFIG:aglcontainerguest = "client"
# systemd integration for the server-side component
PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
@@ -29,9 +29,9 @@ PACKAGECONFIG[server] = "-Dserver=true,-Dserver=false,pipewire"
PACKAGECONFIG[client] = "-Dclient=true,-Dclient=false,"
# server-side systemd service
-SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'pipewire-ic-ipc.service', '', d)}"
+SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'pipewire-ic-ipc.service', '', d)}"
-FILES_${PN} += "\
+FILES:${PN} += "\
${datadir}/pipewire/* \
${libdir}/pipewire-0.3/* \
"
diff --git a/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb b/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb
index 7b6af7ee..82fcf4fe 100644
--- a/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb
+++ b/meta-agl-lxc/recipes-platform/images/guest-image-minimal.bb
@@ -4,4 +4,4 @@ require recipes-platform/images/agl-image-boot.inc
IMAGE_LINGUAS = " "
-IMAGE_ROOTFS_EXTRA_SPACE_append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"
+IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"
diff --git a/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb b/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
index 6a17cbed..f03875b9 100644
--- a/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
+++ b/meta-agl-lxc/recipes-platform/images/lxc-host-image-demo.bb
@@ -13,4 +13,4 @@ IMAGE_INSTALL += " \
${@bb.utils.contains('AGL_FEATURES', 'agl-drm-lease', 'drm-lease-manager', '', d)} \
"
-IMAGE_INSTALL_append_rcar-gen3 = " kernel-module-gles "
+IMAGE_INSTALL:append:rcar-gen3 = " kernel-module-gles "
diff --git a/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb b/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
index 11eb513b..912d868a 100644
--- a/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
+++ b/meta-agl-lxc/recipes-platform/images/lxc-host-image-minimal.bb
@@ -56,5 +56,5 @@ do_rootfs[nostamp] = "1"
ROOTFS_POSTPROCESS_COMMAND += "install_container_images; "
-IMAGE_ROOTFS_EXTRA_SPACE_append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"
+IMAGE_ROOTFS_EXTRA_SPACE:append = "${@bb.utils.contains("DISTRO_FEATURES", "systemd", " + 4096", "" ,d)}"