summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium-browser-service.bb
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-12-03 11:53:34 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-06 14:31:47 +0000
commit639fb2cc3de6bf6211aaa4909c7aabf658c29dc7 (patch)
tree5c40c5feef9d49bfd40a84611918c9b95b75f845 /meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium-browser-service.bb
parentfca7f231bf522024d50303c8f6c6adc3b0b5dee6 (diff)
meta-html5-framework: rename layer and featureicefish_8.99.2icefish/8.99.28.99.2
The new name for the layer is meta-agl-profile-graphical-html5 and the feature is agl-profile-graphical-html5, which better match the other existing features like agl-profile-graphical-qt5. Usage: aglsetup.sh -m $MACHINE agl-profile-graphical-html5 Build minimal image to run HTML5 apps: bitbake agl-image-graphical-html5 Include to agl-demo-platform: IMAGE_INSTALL_append = " packagegroup-agl-appfw-html5" Change-Id: I4a4d4f85dd7fc23be51621702f842aa86a0dc3a5 Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
Diffstat (limited to 'meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium-browser-service.bb')
-rw-r--r--meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium-browser-service.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium-browser-service.bb b/meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium-browser-service.bb
new file mode 100644
index 00000000..2686c7c8
--- /dev/null
+++ b/meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium-browser-service.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Chromium browser widget"
+DESCRIPTION = "Wgt packaging for running chromium installed browser"
+HOMEPAGE = "https://webosose.org"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "gitsm://github.com/webosose/${PN}.git;branch=halibut;protocol=https"
+SRCREV = "7dabb46483ff6a3a4fa5cfe532b91412f185554d"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+#build-time dependencies
+DEPENDS += "af-binder af-main-native chromium68"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += "chromium68-browser runxdg"