summaryrefslogtreecommitdiffstats
path: root/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-09-02 14:20:45 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-09-07 17:07:17 +0000
commit0457026fc28c1914d4e12a444c61f1a25ca257dd (patch)
tree3c9695d9f9507ade9ec2288f01ebc9ff4a4e8c87 /meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb
parent0dd1e7508ac5b710cf0b94fa7e6b56089f760b46 (diff)
meta-agl-test:add new feature 'agl-test'
'agl-test' is used to compile the test sets and test framework into the image, make it more convenient to test target. Now it's only support the target agl-demo-platform(ivi) Enable the `agl-test` AGL feature when setting up your build environment with aglsetup.sh. This will add the `packagegroup-agl-extend-test` packagegroup to the image, For specific packages to be added, please refer to the file: ./recipes-platform/packagegroup/packagegroup-agl-extend-test.bb For running test using 'agl-test', refer to: https://git.automotivelinux.org/src/agl-test-framework/tree/README Bug-AGL: SPEC-4345 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: Ic217bff672f3dae1ac3abc18c01ba802ebcb8fe1
Diffstat (limited to 'meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb')
-rw-r--r--meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb b/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb
new file mode 100644
index 00000000..7ef5d0e2
--- /dev/null
+++ b/meta-agl-test/recipes-tests/agl-test-framework/agl-test-framework.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Agl Test Framework"
+HOMEPAGE = "https://git.automotivelinux.org/src/agl-test-framework/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+PN = 'agl-test-framework'
+PV = '1'
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-test-framework;protocol=https;branch=master"
+SRCREV = "aa5fab53993f29311f1aef83488eb0f759dabca8"
+
+S = "${WORKDIR}/git"
+
+FILES:${PN} += " \
+ /usr/AGL/agl-test/ \
+"
+
+do_install:append() {
+ install -d ${D}/usr/bin/
+ install -m 0755 ${WORKDIR}/git/agl-test ${D}/usr/bin/
+ install -d ${D}/usr/AGL/agl-test/plugins/
+ install -m 0644 ${WORKDIR}/git/pytest.ini ${D}/usr/AGL/agl-test/
+ install -m 0644 ${WORKDIR}/git/conftest.py ${D}/usr/AGL/agl-test/
+ install -m 0644 ${WORKDIR}/git/plugins/* ${D}/usr/AGL/agl-test/plugins/
+}
+
+RDEPENDS:${PN} += " \
+ python3-pytest \
+"