summaryrefslogtreecommitdiffstats
path: root/meta-agl-test/recipes-tests/aio-stress/files/Makefile
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-07-20 14:45:43 +0800
committerduerpei <duep.fnst@fujitsu.com>2022-07-20 14:45:43 +0800
commit75d089e5b25f6ba28f64989a5409542025f5de74 (patch)
tree55628e369c05141e9ee1e7f16d199878580b84bd /meta-agl-test/recipes-tests/aio-stress/files/Makefile
parentfddfe178b414826ecf0c658f94f03eac4a6bd572 (diff)
meta-agl-test: add 'aio-stress' to agl-test
Add the test set of aio-stress to agl-test Bug-AGL: SPEC-4345 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: Ic5bee24e24ef1b89a6212d72c7a0a08725e1fe36
Diffstat (limited to 'meta-agl-test/recipes-tests/aio-stress/files/Makefile')
-rw-r--r--meta-agl-test/recipes-tests/aio-stress/files/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-agl-test/recipes-tests/aio-stress/files/Makefile b/meta-agl-test/recipes-tests/aio-stress/files/Makefile
new file mode 100644
index 00000000..c2b2ffe8
--- /dev/null
+++ b/meta-agl-test/recipes-tests/aio-stress/files/Makefile
@@ -0,0 +1,13 @@
+CFLAGS = -Wall
+TARGET = aio-stress
+
+
+all: $(TARGET)
+
+
+$(TARGET): aio-stress.c
+ $(CC) $(CFLAGS) $^ -o $@ -lpthread -laio
+
+
+clean:
+ $(RM) $(TARGET)