summaryrefslogtreecommitdiffstats
path: root/meta-agl-wireless-monitor/recipes-component/libcgic/libcgic_2.0.8.bb
diff options
context:
space:
mode:
authorYan <yanxk.fnst@fujitsu.com>2023-10-08 08:31:16 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-16 11:46:17 +0000
commitd9670d5543f8a9444ab01d39ad8a95bc1aee3df3 (patch)
tree5427b245d2cbbd453f43eb44b949a8a520ac06d9 /meta-agl-wireless-monitor/recipes-component/libcgic/libcgic_2.0.8.bb
parent0bd14b0af2f8e6751c39899cf8f9fe42e1960b39 (diff)
agl-wireless-monitor: add libcgic
cgic library is now added, test cgi deployed onto board. this library would play a build time dependency role later on. Bug-AGL: SPEC-4838 Signed-off-by: Yan <yanxk.fnst@fujitsu.com> Change-Id: I16d67e2bacabb12bd36f2c439eeee91ef786e7c5
Diffstat (limited to 'meta-agl-wireless-monitor/recipes-component/libcgic/libcgic_2.0.8.bb')
-rw-r--r--meta-agl-wireless-monitor/recipes-component/libcgic/libcgic_2.0.8.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-agl-wireless-monitor/recipes-component/libcgic/libcgic_2.0.8.bb b/meta-agl-wireless-monitor/recipes-component/libcgic/libcgic_2.0.8.bb
new file mode 100644
index 00000000..7b470ef0
--- /dev/null
+++ b/meta-agl-wireless-monitor/recipes-component/libcgic/libcgic_2.0.8.bb
@@ -0,0 +1,22 @@
+SUMMARY = "CGIC library"
+HOMEPAGE = "https://github.com/boutell/cgic"
+DESCRIPTION = "An ANSI C library for CGI Programming."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://license.txt;md5=1ef0cf0c9e6e61f326fd48746179cf38"
+
+SRCREV = "a3490b7612f194f029b6e7a7fc602ad962bc33e2"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/boutell/cgic.git;protocol=https;branch=master \
+ file://0001-modify-makefile-for-cross-build.patch \
+"
+
+EXTRA_OEMAKE = "LDFLAGS='${LDFLAGS}'"
+
+do_install() {
+ install -d ${D}/usr/bin/cgi-bin
+ install -m 0755 ${S}/capture ${D}/usr/bin/cgi-bin
+ install -m 0755 ${S}/cgictest.cgi ${D}/usr/bin/cgi-bin
+}