summaryrefslogtreecommitdiffstats
path: root/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-12-07 15:50:58 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-12-07 18:46:04 +0000
commitfd78578b11990bc885651c52690dbcf9169bd7ac (patch)
tree8e71e64871a41d0f7e3724ecc19063011c56e8c8 /meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
parent3ba897c7b0638797d639f98723bfdb8b4eade2b4 (diff)
Move hal configuration files into own repository
... and own recipe This allows to manage the various types of configuration files independently of the source code as these might not always fit into the git repo context-wise. Initial recipe is 4a-hal-device-config.bb . This is re-using the same mechanism as previously used. Samples for alternative implementations and vendor hals are included as well to explore improved ways of handling the multipe configuration files possible. Bug-AGL: SPEC-2011 Change-Id: Ib04b5c4e7b764bed85dbceb50a62a8c6fd031c5a Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb')
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb35
1 files changed, 4 insertions, 31 deletions
diff --git a/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb b/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
index 264ba951..4b183883 100644
--- a/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/4a-hal-generic/4a-hal-generic_git.bb
@@ -16,39 +16,12 @@ S = "${WORKDIR}/git"
inherit afb-system-cmake
-# FIXME:
-#FILES_${PN}-dev += "${INSTALL_PREFIX}/4a-hal/htdocs"
-#FILES_${PN} += "${INSTALL_PREFIX}/afb-aaaa"
-#FILES_${PN} += "${INSTALL_PREFIX}/lib"
-
-# The package is machine-specific due to variable config content
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-# when no specific HAL is defined, use a generic usb one
-4A_HAL_LIST ??= "2ch-generic-usb"
-
-# for specific machines, activate only known HALs
-4A_HAL_LIST_m3ulcb ?= "rcar-m3 rcar-m3kf"
-4A_HAL_LIST_h3ulcb ?= "rcar-m3 rcar-m3kf"
-4A_HAL_LIST_intel-corei7-64 ?= "intel-minnow intel-upsquared-hdmi"
-4A_HAL_LIST_qemux86-64 ?= "intel-qemu"
-
-# Due to bug SPEC-1610, default hal for RPI3 is not active yet
-# 4A_HAL_LIST_raspberrypi3 ?= "raspberry-pi-3"
-
-### TODO: this list should be completed for more machines
-
do_install_append () {
# get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
- # move all config files to a 'available' dir
- mv $PKGDIR/etc $PKGDIR/etc.available
-
- # then install only required hals files in the etc folder
- mkdir -p $PKGDIR/etc
- for x in ${4A_HAL_LIST}; do
- hal=hal-4a-$x.json
- mv -v $PKGDIR/etc.available/${hal} $PKGDIR/etc/
- done
+ # transition: provided by separate package
+ rm -rf $PKGDIR/etc
}
+
+RDEPENDS_${PN} += "virtual/4a-default-hal"